3

I have a Lenovo laptop running Windows 10 that I use both standalone when I'm on the go, and connected through a dock to a monitor, keyboard, and mouse when I'm at home.

When I'm out, I use the fingerprint reader to log in. However, when I use it at home, I have the cover closed, so the fingerprint reader is not easily accessible, so I use the keyboard to log in.

When using the keyboard to log in, I prefer to log in via PIN, rather than password. If I log in via PIN multiple times while I'm at home, it remembers my last login method each time, and makes PIN the default login option. However, if at any point, I use fingerprint login, it changes the default login method back to Keyboard, so the next time I use it at home, I have to do two mouse clicks to change it back to PIN again. I know it's not a huge problem, but it is annoying to have to do that.

Is there a way to prevent it from switching the default login method from PIN back to Password every time I use the fingerprint reader to log in?

7

Check this article on how to set your default sign-in option in Windows 10 using a registry tweak.

  1. Press the Windows + R keys together, and then type regedit and hit Enter to access Registry Editor.

  2. Navigate to the registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserTile

  3. Find your current account's SID on the right pane, and double-click on it to modify.

  4. Type {D6886603-9D2F-4EB2-B667-1971041FA96B} in the Value data field and click OK.

  5. Reboot your computer and it will display PIN as your default sign-in option on the logon screen.

GUID for each sign-in option:

  • PIN: {D6886603-9D2F-4EB2-B667-1971041FA96B}
  • Picture Logon: {2135F72A-90B5-4ED3-A7F1-8BB705AC276A}
  • Password: {60B78E88-EAD8-445C-9CFD-0B87F74EA6CD}
  • Fingerprint Logon: {BEC09223-B018-416D-A0AC-523971B639F5}
  • I tried this, but it only worked once. Here's what I did: 1) Followed your instructions. 2) When I rebooted, it did indeed default to PIN as the default login option. 3) I swiped my finger to log in. 4) I hibernated my laptop. 5) I resumed from hibernation. 6) When it came back up, the default was Password. – JoeMjr2 Mar 12 '17 at 19:08
  • You might need to create a .bat script to make this registry changes, schedule the script to run every time you log on to Windows. – Durfee Mar 16 '17 at 5:04
  • It seems to be working well now, without a batch script. Not sure why it showed Password that one time. Accepting answer. – JoeMjr2 Mar 17 '17 at 15:33
  • Worked great after applying permission rules suggested by RonnieGP. Thanks! – BlueDev Aug 22 '18 at 10:39
0

I know this is an old thread, but there is a way to force Windows 10 to default to the Windows Hello Fingerprint Login screen, regardless of the previous login method (password or PIN). The idea is to prevent the system from changing the login method associated with your user account in the registry on every boot . First, find you user name's SID by entering "wmic useraccount get name,sid" (without quotes) in a command prompt window. Make a note of the SID so you can find it in the next steps.

IMPORTANT: Set a System Restore point first, just in case something goes wrong. Best to be safe!

Using RegEdit, navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserTile Find your user key SID and change the value to {BEC09223-B018-416D-A0AC-523971B639F5} (include the brackets) which is the fingerprint logon method. It may be already there, depending on the login method used when you last booted up. If so, just leave it as is. Right click the "UserTile" folder and click "Permissions" Click Advanced and in the new window, click "Disable inheritance" and select "Convert inherited permission into explicit permission on this object." in the popup window, then "Apply". Double-click on "Administrators", click on "Edit", and make sure that "Type" is set to "Allow" and that "Full Control" is checked, which should be the default. Assuming it is, click on "Cancel". Double-click on "System", click on 'Edit", set "Type" to "Deny", click "show advanced permissions"and uncheck all the boxes except for the "Set value" box. That is the only box that should checked. Check the box that says "Only apply these permissions to objects and/or containers within this container" if it is not already checked. Click OK on all boxes until all permissions windows are closed to save your settings. Just to make sure, right-click the "UserTile" key again, select "Permissions", click "Advanced" and go to the "Effective Access" tab in the window. Click "Select a user", type "SYSTEM" (without quotes"), click "OK", and click "View Effective Access". Confirm that there is an "X" next to "Full Control" and "Set Value", and that all the other entries still have a green checkmark. If so, you can just cancel out of all the permissions windows and close the registry editor. On every subsequent reboot, you should now see the Windows Hello fingerprint login screen.

This method worked perfectly for me. The only possible issue I see is if you decided to add a new user as the inability of the SYSTEM to change this key's registry values might be problematic, but I haven't tried it. In that case, you should be able to give full control back to SYSTEM permissions temporarily, add the user, and repeat the above steps to prevent the SYSTEM from from changing values in this UserTile registry key for both users. Note that you can set the default login method for each user individually.

If anyone is still following this thread and wants to try it, let me know if it worked out for you.

0

To add onto Durfee's answer, here is the line you need for a batch file to constantly have the setting changed to what you want.

reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserTile /v Enter_your_current_account_SID_here /t REG_SZ /d {60B78E88-EAD8-445C-9CFD-0B87F74EA6CD} /f

Dont forget to change that code so it has your SID, which can be found as the name of the key thats already in there.

Now you can create a task in Task Scheduler that runs the script on every workstation unlock. That way you can continue to use fingerprint unlock and no matter what, it will always show the password (or whichever prompt you have specified with the value) on the lock screen.

0

I was surprised about all the answers with registry solutions. But you ony need the registry for the right credential providers and its CLSID.

It's much better and easier to use the local group policy editor for this.

Choose the right credential provider from here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Providers

In this case it's the WinBio Credential Provider: {BEC09223-B018-416D-A0AC-523971B639F5}

In the Local Group Policy Editor window, go to: Computer Configuration -> Administrative Templates -> System -> Logon

In the right pane, look for the policy setting named "Assign a default credential provider". Edit this policy and change it to Enabled state. In "Assign the following credential provider as the default credential provider" input box, type the CLSID {BEC09223-B018-416D-A0AC-523971B639F5}.

Click Apply followed by OK. You can close the Group Policy Editor and reboot to make changes effective.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.