0

I was recently looking for a solution to stop Dropbox from fighting with Svn for priority over the ShellIconOverlayIdentifiers in the system registry.

One solution was to set the permissions on the key to deny write access. However it seems I've made a grave error and have been a bit over zealous with revoking these permissions.

Now I just get errors when trying to look at the permissions let alone update them. I've tried running RegEdit as Administrator but that still doesn't allow me to view or change the key. I just keep getting the message:

Error Opening Key

ShellIconOverlayIdentifiers cannot be opened. An error is preventing this key from being opened. Details: Access is denied.

If I run RegEdit as adminstrator I still cannot view the contents. If I right-click and select Permissions I get a warning message saying:

Windows Security

You do not have permissions to view the current permission settings for ShellIconOverlayIdentifiers, but you can make permission changes.

Which seems a little odd.

Is there any way I can recover from this situation or is this now a lost cause?

5
  • 1
    Does opening the registry as the SYSTEM user help? See this answer Unable to delete registry key – DavidPostill Mar 11 '17 at 18:31
  • YES!! David, post your comment as an answer so I can give you some love! Thank you, that worked! – Jammer Mar 11 '17 at 18:42
  • 3
    Possible duplicate of Unable to delete registry key – DavidPostill Mar 11 '17 at 18:44
  • The proper thing for me to do is close this question as a duplicate of the other one - not try and gain rep. The proper thing for you to do is upvote the answer to that other question. – DavidPostill Mar 11 '17 at 18:44
  • True, but to be fair I would never have found that answer given my situation and googling hadn't turned that up. – Jammer Mar 11 '17 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.