2

I have Windows 10 (home premium) installed on a SSD in a desktop. It was booting just fine until a couple of months ago.

I CAN boot Windows in SAFE MODE.

I have a Windows 10 DVD that I burned myself after I upgraded from Windows 7.

My personal files are on another drive, so no worries about loosing them.

I have the passwords for the two accounts I created when I originally installed Windows 7, which have not changed since. One is administrative the other a regular one.

I also have Linux installed and GRUB (boot loader) but I don't think they are involved in this problem. Linux (Xubuntu 16.04 LTS) is installed on a HDD and is booting fine, except that sometimes I have two NTFS partitions on the same HDD, to be shared between systems, that periodically need fixing with a one liner but that's it. I think that this is caused by some of my failed attempts to start Windows. Whatever causes it I'll deal with it later.

The two (2) NTFS partitions in question are also on the HDD with Linux.

The EFI System Partition (fat32 or vfat) used to boot Windows is the first partition on my SSD, first drive, no letter in Windows. Windows is on C:.

I am desperately trying to avoid re-installing Windows because I have many installed drivers/programs & settings tweaks, and because I worry I will mess up my Linux installation. I know that Windows behaves badly with other OSes.

I believe that the problem so far with Windows is independent of GRUB and Linux because I select Windows directly from the UEFI screen, not going through GRUB, and I get a few reboots followed by:

Recovery

Your PC couldn't start properly. After multiple tries...

Error code: 0xC0000001

You'll need to user recovery tools

It all started with my attempts to fix the problem with:

bootrec /fixmbr

which produced:

cannot find the file specified.

I tried booting with my Windows-10 DVD which works but none of the suggestions I found on the Web were fruitful for me, including Startup Repair:

Startup Repair couldn't repair your PC.

Press "Advance options" to try...

Log file: C:\WINDOWS\System32\LogFiles\Srt\SrtTrial.txt

I copied that file to read it later in Linux but the text editors I used (leafpad, mousepad) were unable to open it. I tried all of the encodings shown in Mousepad, two dozens of them, but none worked.

I then tried a whole bunch of stuff, including:

> bootsect /nt60 sys
> bootrec /rebuildBCD
> DISKPART list vol, sel vol ('3' for me), assign letter= ('S' for me)
> bcdboot C:\WINDOWS /s S: /f UEFI

and

C:\Windows\System32>msconfig

produced:

You do not have sufficient privileges ...

and

X:\Sources>sfc /scannow

produced:

Beginning system scan...

Beginning verification phase...

Verification 100% complete.

Windows Resource Protection could not perform the requested operation.

At this point I need to ask for help because I'm starting to get lost in my notes and it's time consuming to have to boot into Linux to do what I'm doing now, then write everything down on paper, then reboot into Windows, then try, write down the results, reboot into Linux and start that sequence again. I only have one computer. As far as my research and my attempts at solving this, I am past the point of diminishing returns now.

EDIT (1)

UEFI screen options:

CSM Support: Always

  • Boot Mode Selection: UEFI Only

  • PXE Boot Option Control: Disabled

  • Storage Boot Option Control: UEFI First

  • Display Boot Option Control: UEFI Only

Other PCI Device ROM Priority: UEFI OpRom

I have played (worked painstakingly) on booting problems in the past with this machine, starting with Xubuntu 12.04 and Windows 7 and I need to be very careful with these settings. I am not absolutely certain that it is still true but selecting "Never" for "CSM Support" (legacy mode) prevented booting when I had made sure that everything was strictly GPT and UEFI. It didn't seem logical to me but that's what happened. Ever since my initial installation of both OSes, back when I didn't know much about UEFI and ended up making mistakes even if I had decided from the start to be exclusively UEFI (to make thing simpler... ha ha ha). So that's why you see here "Always" for CSM Support and "UEFI Only" for Boot Mode Selection, this second one being the important one I think.

EDIT (2)

As a side note I just saw a post on another forum by chance where there is an option in Windows 10 -> Troubleshoot -> Advanced options called "UEFI Firmware Settings" which IS NOT present here on my system. I don't know if it matters but I thought I should post this just in case. There is something I don't know. I know for a fact that my installation of Windows and Linux are UEFI and that both drives (1 ssd, 1 hdd) are GPT formatted, so I don't know why I'm not getting that option.

EDIT (3)

Hibernation is NOT enabled in Windows. (I verified using Safe Mode, the only way I can get into Windows.)

EDIT (4)

I tried booting Windows with "clean boot", i.e. disabled all non-Microsoft services in System Configuration (msconfig) and all items in Task Manager Startup tab. The result was the same.

Any suggestion would be appreciated.

Thanks in advance.

  • Re bootrec /fixmbr and bootsect /nt60 . You are probably using UEFI on GPT, not MBR with a boot record. Any command to mess with a not-existing (and not needed) MBR or bootsector will not solve your problem. – Hennes Mar 12 '17 at 12:59
  • @ Hennes: Yes gpt formatted, UEFI only for both my SSD and my HDD. Thanks for that. – hockeykong Mar 12 '17 at 17:21
  • my motherboard: Gigabyte GA-Z77X-UD3H rev-1 – hockeykong Mar 12 '17 at 17:26
  • QUESTION: I don't want to cross post but maybe I could ask in a strictly "windows" forum about my "EDIT (4)"? (What to do when doing a clean boot doesn't allow to boot normally?) I'm thinking that perhaps my original question here should have been asked in a forum geared for regular users instead of "Super" users ;-) I'm not sure. – hockeykong Mar 15 '17 at 15:01
  • "Never" for "CSM Support" (legacy mode) prevented booting when I had made sure that everything was strictly GPT and UEFI. It didn't seem logical to me but that's what happened. Uhm. that confuses me. Do you have grub on MBR/in_partition and windows on ESP/bootx64.efi? – Hennes Mar 15 '17 at 19:35
4
  1. Boot your Windows 10 DVD using UEFI boot (or disable CSM, so you cannot boot using boot records)

  2. Map EFI System on SSD to Z: using diskpart

  3. bcdboot c:\windows /s Z: /f UEFI

assuming c: maps to Windows partition on SSD.

Forget about unreliable bootrec - the main problem seems to be inability to find EFI System.

Other problem you have - disable fastboot so Windows 10 does a full restart (and full shutdown)

And ... forget about MBR on UEFI (one of the main reasons for implementing EFI is to get rid of MBR and its limitations and problems)

  • Done for 1, 2, 3: same result as before, "Boot files successfully created", I then rebooted in my Windows installation on SSD, and the result is: "Recovery", "Your PC couldn't start properly", "After multiple tries...needs to be repaired", "Error code: 0xc0000001" ... – hockeykong Mar 12 '17 at 17:35
  • The only option in my UEFI screen that may be related to "fastboot" is called "Intel Rapid Start Technology" and it has always been disabled and still is. I just verified again. – hockeykong Mar 12 '17 at 17:38
  • I added a layout of some UEFI options followed by comments. If we determine that I MUST select "Never" for "CSM Support" (i.e. that "UEFI Only" for "Boot Mode Selection" is not enough) I will do it. Unless you or someone else tells me otherwise and is fairly certain, I'd rather keep it as is. – hockeykong Mar 12 '17 at 18:22
  • I mean it is easier not to use CSM boot (=MBR boot) when you have UEFI/GPT disk. Then you can boot external media only UEFI way. CSM is only useful for older versions of Windows - Windows 7 for example needs CSM when booting to recovery. – snayob Mar 13 '17 at 4:38
  • 1
    "fastboot" is part of Windows 8/10 power settings - something like hibernation when you shut down (for faster start-up later). BUT when you dual-boot hibernation means remembering state of open files and when you use another OS in the meantime disk gets corrupted for the hibernated OS. – snayob Mar 13 '17 at 4:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.