2

I want reCAPTCHA to be shown in English on all websites i visit like sign up pages and etc, but it is in Persian. Like this:

Image

I tried Changing language in account settings to refresh it, clearing cookies, history, etc. Nothing worked.
How can I change the language reCAPTCHA uses for me to English?

UPDATE
I tested on IE and Edge browser and reCAPTCHA is English in those browsers. just in chrome it is still Persian. any suggestion to make it English on Chrome?

4
  • 2
    FYI, Google is releasing a new reCAPTCHA which will be completely invisible: arstechnica.com/gadgets/2017/03/… google.com/recaptcha/intro/invisible.html But to answer your question, it looks like you can force it to render in a specific language: developers.google.com/recaptcha/docs/display#config – wysiwyg Mar 12 '17 at 6:36
  • @wysiwyg I'm pretty sure it is not forced to Persian.because: 1. Site is in USA and is in English language 2. I live in Iran, but my account language settings are English. Please let me know if i have missed anything in settings, or any help – mohammad sarabi Mar 12 '17 at 6:53
  • I misunderstood your question, I thought you were talking about a specific reCAPTCHA that you are putting on your website. But you mean all reCAPTCHAs on all websites display to you in Farsi? And you're sure your google language is set to English? myaccount.google.com/intro/preferences – wysiwyg Mar 12 '17 at 7:00
  • @wysiwyg That's right. both my "Language" and "Input Tools" are on English, and it is only language i specified for my account but still all reCAPTCHAs in all websites are Persian/Farsi. i tested here at Demo reCAPTCHA and also this page is shown in persian. – mohammad sarabi Mar 12 '17 at 7:11
3

its depend on what is your version recapcha.

in version 2

You just need to specify the parameter "?hl=" in the script's url:

<script src='https://www.google.com/recaptcha/api.js?hl=fr'></script>

in version 3

You just need to specify the parameter "?lang=" in the script's url:

https://www.google.com/recaptcha/api.js?render=reCAPTCHA_site_key&lang=en
1

I checked languages in chrome settings and there was Persian language beside English. After removing Persian everithing is fine now and reCAPTCHAs are showing in English.

0

Change language in reCaptcha url explicitly,

https://www.google.com/recaptcha/api.js?explicit&hl=fa'> for Persian or https://www.google.com/recaptcha/api.js?explicit&hl=en'> for English or any other language

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.