0

Macbook Air with Mac OSX v10.11.5 & Bootcamp running Windows 10. I primarily boot to Windows. For some reason, a new wifi network I'm trying to connect to isn't showing up within Windows. If I boot to Mac, the network will show up (sometimes right away, sometimes it takes about a minute). It's the same hardware (obviously), and I've connected to countless other wifi networks with the Windows OS, just yesterday I was connected in fact (a different network).

I can see other wifi routers within Windows, so it's not an issue of the network card or drivers AFAIK. In fact the same hotspots I see in Mac, also show up in Windows -- except for this one network to which I actually know the password.

I've tried to manually add the network in Windows as well. Adding the SSID manually along with the WPA2 password. It still doesn't connect.

I can connect with my Android phone to the network and the connection works fine both LAN & WAN. Same on Mac. Just not on Windows. I've never experienced this before. Any ideas?

  • What channel is the network on? – Spiff Mar 12 '17 at 18:19
  • Not entirely sure. I can't access the admin interface of the router over WiFi. It requires a direct cat5 connection which I don't have access to. – sixside Mar 12 '17 at 21:00
0

It may be a 5ghz network and your WiFi driver under Windows only supports 2.4ghz networks, it may also be an AC network and your driver supports up to N networks.

The fact that the Mac may sometimes need time to find the network may mean that the network card has difficulties in receiving that network. The card's support for that network's broadcast-type may be limited or reception quality might be poor.

Nevertheless, updating the Windows driver to the latest version may help. More information is required about your Mac model, Boot Camp version, network card and driver version to verify your driver.

| improve this answer | |
  • Bootcamp is version 4.0 on a MacBook Air (13-inch, Mid 2011) Serial Number: C02H400BDJWR with Broadcom 802.11 network adapter with driver version 6.30.223.256. I don't have full admin access to the wifi router (I'm staying in an Airbnb) as it seems configured to only allow admin access over a cat5/wired connection. No 'remote' access. – sixside Mar 12 '17 at 20:54
  • One other piece of info. I booted into a Live Linux OS, and it found the network and connected just fine. So certainly seems to be Windows 10 specific. – sixside Mar 12 '17 at 21:02
  • From within OSX I can see the network I'm having issues with is connected via 802.11n on Channel 13 – sixside Mar 12 '17 at 21:22
  • There is newer software (see link1 and link2), but I'm not sure that major updates to your computer while away from home is a good idea. The problem is clearly with Windows and updating should start with the network driver and possibly go all the way to BIOS, better done at home-base after taking good backups and with a second functioning computer nearby. – harrymc Mar 13 '17 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.