1

My usb 3.0 is not working. I tried to install different drivers but no avail.

enter image description here

System info enter image description here

  • upgrade to Windows 8/10, they have a generic inbox usb 3.0 driver – magicandre1981 Mar 12 '17 at 18:02
  • I got it working. not sure what solved it but after installing a bunch of kb files from HP and rebooting its working now. – Vlad Mar 15 '17 at 8:16
  • post as answer which KB files you downloaded and installed. – magicandre1981 Mar 15 '17 at 16:48
1

I hope this helps. I don't know which one made it work but the list below are the one I installed.

https://downloadmirror.intel.com/21129/eng/Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver.zip

https://downloadmirror.intel.com/22824/eng/Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver_4.0.6.60.zip

http://whp-hou9.cold.extweb.hp.com/pub/softpaq/sp54501-55000/sp54511.exe

http://whp-hou9.cold.extweb.hp.com/pub/softpaq/sp58501-59000/sp58725.exe

After installing the KB's I made a full shutdown and Turned on. Now its working.

0

Have you tried using a tool like DriversCloud to find the right drivers for your device ?

If it doesn't, this tool will also help you to find the precise model of device, because Renesas Electronics has really large series of "USB 3.0 Host Controller". You can then post it here.

  • no I haven't tried. – Vlad Mar 16 '17 at 8:28
0

This did the trick for me:

Website: https://plugable.com/drivers/renesas/

Direct driver download: https://s3.amazonaws.com/plugable/bin/Renesas/2014-03-Plugable-Renesas-USB-3.0-200-2.1.39.0.zip

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.