17

Methods Failed to disable Microsoft Compatibility Telemetry:

Method 1: Use O&O ShutUp10 Used latest version released on 7-Mar-'17

Method 2 (CMD commands) mentioned here :

sc delete DiagTrack
sc delete dmwappushservice
echo "" > C:\ProgramData\Microsoft\Diagnosis\ETLLogs\AutoLogger\AutoLogger-Diagtrack-Listener.etl
reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows\DataCollection" /v AllowTelemetry /t REG_DWORD /d 0 /f

Method 3 (Disable appraiser) mentioned here : Disable the Microsoft Compatibility Appraiser task in Task Scheduler under \Microsoft\Windows\Application Experience.

Method 4 (Disable all tasks under \Microsoft\Windows\Application Experience) mentioned here : Disabled all tasks (Microsoft Compatibility Appraiser, ProgramDataUpdater, StartupAppTask) under \Microsoft\Windows\Application Experience.


Microsoft Compatibility Telemetry is known for its high disk and CPU usage and suspicious anti-privacy activities.

I've used the previous methods to disable it but all of them failed to disable it, as it returns to run again.

Task Manager

Moreover, weird activity was detected via Process Monitor where Compatibility Telemetry is trying to write files to my antivirus location. Screenshot: enter image description here

  • What makes you think it doesn't work? – DavidPostill Mar 13 '17 at 17:50
  • 1
    disable the Microsoft Compatibility Appraiser task in task scheduler: superuser.com/a/1069212/174557 – magicandre1981 Mar 14 '17 at 15:49
  • 1
    disable all tasks under Microsoft\Windows\Application Experience – magicandre1981 Mar 20 '17 at 16:56
  • 2
    Do you run automatic windows update? It seems that on my computer it came back at the same time I did the Windows 10 Creator Update. Maybe it overwrites previous settings. Since re-disabling it, it didn't showed up again yet. I follow the Windows10Club page to do that. thewindowsclub.com/windows-10-telemetry – Flox Apr 26 '17 at 7:25
  • 1
    I confirm that none of the potential solutions mentioned here works since Creator's Update. I'm contemplating writing a small tool that will monitor the list of running processes and just terminate this annoyance. – Violet Giraffe Sep 18 '17 at 18:53
2

I had similar problem in my laptop, the telemetry consumes all disk IOs after I install anything new or updates. Making it unusable for a few hours.

Here how I solved:

  1. Make sure the telemetry is not running (you can stop it from the task manager)

  2. Open your %windir%\system32\

  3. Find the trouble maker CompatTelRunner.exe

  4. Gain ownership on the file (Properties -> security tab -> advanced -> owner change, set yourself as owner)

  5. Add permission to modify for the users (select "users" -> edit -> basic permissions-> check modify -> ok)

  6. Click ok again

  7. Rename the CompatTelRunner.exe to CompatTelRunner.exe.bak for example

The telemetry will not run any more. until you restore the windows or a major windows update.

PS:This solution might generate some error log entries.Because windows will still trying to run it.

  • It's not that easy to change the access rights on a TrustedInstaller owned binary, unfortunately. Also, strangely enough, when I tried running a third party Explorer clone (because explorer.exe is hard coded to never start as TrustedInstaller / Administrator) CompatTelRunner was no longer listed in C:\Windows\System32! It didn't show up in cmd either. I wasn't able to find a way to rename CompatTelRunner. – jrh Jul 11 '19 at 19:20
  • Are you a local admin in your machine? @jrh – Alexrgs Aug 7 '19 at 21:55
  • Yes I am a local admin – jrh Aug 8 '19 at 2:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.