I downloaded the latest FFMPEG for Windows (Version 3.2.4).

I wanted to use it for converting a MOV File which contains qtrle uncompressed video.

The video can be downloaded on this link - https://www.sendspace.com/file/qjjkhj.

I can view the video in VLC Media Player yet when I try convert it in VLC into any video format the output is invalid video file.

I also tried using FFMPEG using the following command - ffmpeg -i DL126H.mov -c:v copy VideoClip0002.mp4. Yet the result was: [mp4 @ 00000000026744e0] Could not find tag for codecqtrlein stream #0, codec not currently supported in container Could not write header for output file #0 (incorrect codec parameters ?): Invalid argumentStream mapping:.

I also tried the following - ffmpeg -i DL126H.mov -c:v mpeg2video -b 16M out.mpg yet the output, just like in the case of VLC was invalid video file.

So I'd like the assistance with:

  1. Convert into Windows friendly format (With High Quality)?
  2. Change container into format working in Windows (With no rencoding).
  3. Convert into valid MPEG2 (.mpg) with high bit rate.

Thank You.


1 Answer 1


The syntax is simply

ffmpeg -i DL126H.mov -pix_fmt yuv420p VideoClip0002.mp4

This will encode using default parameters i.e. using libx264 at CRF 23 and AAC at 128 kbps.

To use custom parameters, like better video quality, use

ffmpeg -i DL126H.mov -crf 18 -pix_fmt yuv420p VideoClip0002.mp4

This will preserve more of the source quality but a larger file

In FFmpeg's case, the 'release' build is never the latest version. Always go for the nightly/snapshot/git build.

If you want to encode to MPEG-2, use

ffmpeg -i DL126H.mov -c:v mpeg2video -b:v 16M -bufsize 30M -maxrate 30M -pix_fmt yuv420p VideoClip0002.mp4

The MPEG-2 spec was designed during SD video days and its defaults are not suitable for HD video. So a couple of them have to be manually overridden. The result plays for me in WMP12.

  • Could you explain what you did? What if I want to encode as MPEG2? What about just changing the container into MP4?
    – Royi
    Mar 14, 2017 at 12:16
  • 2
    FFmpeg does not support writing qtrle into MP4 so that's not possible. My first command (of the form ffmpeg -i input output) converts input into output using default choice of codecs and their conversion parameters. I've added -pix_fmt yuv420p as that's the only pixel format supported by web players, and qtrle is RGB for which ffmpeg will default to yuv444p for output. Playable in some players only. To encode to MPEG-2, use your command but add the pix_fmt.
    – Gyan
    Mar 14, 2017 at 12:24
  • I tried the pix_fmt with my command and the output video is invalid (MPEG2). Maybe MPEG2 requires different Pixel Format? What's the default Pixel Format for MPEG2? Thank You.
    – Royi
    Mar 14, 2017 at 12:28
  • The same. See answer edit.
    – Gyan
    Mar 14, 2017 at 12:44
  • I tried your new command line. It really managed to remove the Buffer Under run issues of ffmpeg. Thank You! By the way, how can I make FFMPEG use only the first n frames?
    – Royi
    Mar 14, 2017 at 12:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .