8

I use vim on Mac OS X, but this is realy slow in Terminal.app and iTerm.

Progress over many lines becomes tedious.

some idea of solution?

  • Need more details. Are other commands slow? Does ps/top or ActivityMonitor show lots of CPU usage by other processes? Are you editing a very large file? – Doug Harris Mar 11 '10 at 21:17
  • I only see vim slow. When I try down the cursor through of many lines, the processor monitor show many activity. No very long files, approxemately 200 lines. – juanpablo Mar 12 '10 at 0:52
  • Is this only a problem with auto-repeat, or is Vim sluggish when you enter text or navigate up/down with individual key presses? Have you checked your key auto-repeat rate in System Preferences? – Chris Page Aug 15 '12 at 3:10
  • I experienced the same thing and this solved it for me: superuser.com/a/513526/223984 – jsageryd May 13 '13 at 13:07
5

For me, deleting .viminfo helped.

  • 1
    Although this did make it slightly faster, it does not become nearly as fast as the same Vim configuration on a Linux machine without even deleting this file. – Tim Visee Nov 20 '17 at 10:52
2

Maybe you have installed some broken plugins or something like that. Try to temporary rename directory with vim configs:

mv ~/.vim ~/.vim.backup

And/or main config file: mv ~/.vimrc ~/.vimrc.backup

And try to use vim without configs

  • I try with a empty .vimrc file, but nothing is better – juanpablo Mar 15 '10 at 15:42
2

Try MacVim. There is also a 64 bit version available somewhere on the blog, which includes a new rendering layer.

2

I had this problem (just painfully slow) and it ended up being the Consolas font I was using in Terminal.App and ITerm Switching to Monaco in my case sped things up considerably

  • my only solution xterm – juanpablo Jan 21 '11 at 13:09
  • not the issue for me. – user75525 Jul 8 '11 at 4:51
2

I regularly have problems, a few commands are just slow at redrawing. This is a shot in the dark but if you are using cursorline, try disabling it, it dramatically improved performance for me

1

For me, using a Retina iMac, neovim, tmux, and a bunch of neovim plugins, I found that the only thing that made a difference in scrolling & rendering speed was keyboard repeat rate! Nothing else — Terminal.app vs iTerm.app, neovim vs vim, no vim configuration vs my usual, tmux vs no tmux, cursorline vs no cursorline, etc — made any real difference in the slow rendering & scrolling I experienced.

Once I set key repeat faster than available through System Preferences, rendering & scrolling in vim became 2x as fast, regardless of whether I was loading all my plugins or not. I wrote a bit more about the factors I investigated in this comment on tmux issue #353.

I would investigate whether keyboard repeat rate improves the situation for you.

0

Check if you have any other mapping which starts with 'hjkl' in your vimrc. When you have some other mapping starting with these, vim waits to check the next input which results in reduced responsiveness.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.