1

After update to the latest version of firefox (52.0), when I enter on google.com* I get:

Your connection is not secure

Without the chance to add an exception.

Without luck, I tried:

  • Delete cert8.db and cert_override.txt
  • Adding manually the line for google on cert_override.txt (obtained from another machine)
  • Delete certificates (Options->Advanced->Certificates->Authorities->GeoTrust->Google Internet Authority G2)
  • New empty profile
  • Current profile refresh (firefox suggestion)
  • New installation of firefox
  • Cleared all Firefox history (with all options ticked)
  • Change the date/time to 2015 and then back to 2017
  • Use Agent switcher

My addons are:

  • Enchanced Steam
  • uBlock origin
  • Instant translate: Select and translate
  • Tampermonkey

I don't have plugins except for Flash (Ask to activate), OpenH264 and Widevine Content Decryption with Never activate.

On the same machine, on google Chrome google works good and on another machine with firefox also works good, so, I think is not a firewall configuration.

What else can I do to enter on google.com* on firefox en-US 52.0 (64-bit)?

EDIT: enter image description here

EDIT 2: I have currently installed Trend Micro OfficeScan Agent as virus/spyware protection. I can't disable it because is a work machine.

On all browsers I have to configure a proxy. Here is the information: (No proxy for internal addresses) enter image description here

  • Try downloading a copy of Firefox Portable from PortableApps.com and see if you can reproduce your problem in it. Then announce the result here. It will help us isolate the problem. – user477799 Mar 14 '17 at 13:40
  • @FleetCommand It is necessary? I tried with the binary version of firefox (decompress and use) and the result is the same. is a work machine and I don't want portable apps here. Thanks for your answer – jotapdiez Mar 14 '17 at 13:42
  • You have tried everything that immediately comes to mind! Maybe if you do this, we get an epiphany. So, yes, desperate times requires desperate measures. – user477799 Mar 14 '17 at 13:44
  • @FleetCommand ok, let me try that. – jotapdiez Mar 14 '17 at 13:44
  • 1
    Is it possible that you’re using anti-virus software such as Avast, Bitdefender, ESET or Kaspersky and that this software is using a MITM proxy to intercept HTTPS traffic? In such cases, they might have installed a root certificate in the Windows certificate store. which is used used by Chrome (but Firefox manages its own set of root certificates). – Anthony Geoghegan Mar 14 '17 at 15:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.