1

I am filling in a large form in Adobe Reader. (This is for a grant application, and those forms tend to be 80 pages long, with lots of text in the form fields.)

Adobe Reader has by default spellchecking enabled for the form fields, but this relies on a dictionary in a single language. In my case the wrong language. Moreover, sometimes even multiple languages are used in such forms.

Spell checking in this case is annoying and slows down the editing. It even hampers readability.

Therefore I want to disable spell checking totally.

In theory the spellchecker can be disabled via Edit --> Preferences --> Spelling

I did this, but the spellchecker still does its useless & annoying job.

Solution?

1

I have acrobat reader for Mac version 2019.008.20080.

I could easily go to Preferences > Spelling and add another language. I did close and reopen acrobat reader, but that may not be necessary. It does, however, take a little bit for the spell checker to start working (I guess it downloads the dictionary, which means it will depend on your internet speed how long it takes) - for me it took around 20 seconds before it actually showed me the typos.

1
  • Thanks for sharing your experience. I suppose, things improve step by step with newer versions of Acrobat Reader... – Christian Geiselmann Oct 31 '18 at 20:18
0

Here are three different solutions I found:

1) Download Adobe Reader in the language you plan to fill in your form.

Stupidly, Adobe Reader by default seems to come only with a single spelling dictionary (in my case German). So, a second Reader (with the correct dictionary) should help.

(I did not test this myself because I do not have the right to install software on my office computer)

2) Install the Adobe Reader Spelling Dictionary Pack

For Adobe Reader XI:

Adobe - Adobe Reader : For Windows : Adobe Reader XI Spelling Dictionary Pack

For Adobe Reader DC:

Adobe - Adobe Reader : For Windows : Adobe Reader DC Spelling Dictionary

In my Adobe Readers (both XI and DC), this did the job. Puh!

3) Change the settings, then shut down Adobe Reader and restart

This is silly, but this seems to work. I observed this behaviour in my Adobe Reader XI.

Change settings in Edit --> Preferences --> Spelling, then shut down the programme, and restart; then the changed settings seem to work.

However, unfortunately I discovered this just after I installed the language pack mentioned above, so - no guarrantee that it works in a "naked" Reader, too.

Later additional experience: This method worked for me also in Adobe Acrobat X Pro: I changed the language for spellchecking (Edit --> Preferences --> General --> Spelling). This had no effect at first. I then closed the programme, and restarted it, and now the newly selected language was applied to spellchecking the contents of the pdf form.


It took one and a half hours to find these solutions. What a mess. Couldn't they just add a button "download more dictionaries" to their settings? And of course make them work without restart?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.