6

I've been experiencing this problem since... ever, with any Thunderbird version (at the moment I'm using 45.8.0), both Windows and Mac OS.

On all my IMAP accounts I use server-side filters (e.g. GMail labels).

When I open Thunderbird or I search for new messages, my subfolders unread emails count doesn't get updated. So, If I want to know if there are new emails inside a particular folder, I have to click on this folder: this way the unread message counter updates and, of course, I see new messages. Pretty uncomfortable.

If I use local (i.e. to the client, not server-side) filters, this problem doesn't happen.

I've searched the Internet a lot about this problem, but never found a solution. Any suggestion? Any hidden option to tweak?

Thank you

2 Answers 2

3

You can set mail.check_all_imap_folders_for_new (or mail.server.default.check_all_folders_for_new) to true in your config to make Thunderbird always check all folders (including new folders in the future).

To edit the config, go to Menu -> Preferences -> Preferences -> Advanced -> Config Editor. You can search by "check_all" to find the option and set it to true.

Refer to @Gruce's answer when you only need a few folders updated, but not others.

Reference:

Mail and news settings - MozillaZine Knowledge Base

New messages in IMAP folders do not automatically show - Mozilla Support Forum

2
  • Thanks for your feedback, @zypA13510. mail.server.default.check_all_folders_for_new is already set to true. I'm still experiencing this problem in 2019 (with version 60.8.0), randomly.
    – eleftrik
    Aug 27, 2019 at 7:23
  • 1
    @eleftrik It's sad this doesn't solve your problem. I tried this yesterday and it worked for me immediately. Maybe it'll be useful to other people in the future, let's hope.
    – zypA13510
    Aug 27, 2019 at 8:04
2

I've had this problem too, I've got Thunderbird v52.4.0 (64-bit). Over time, I noticed that some sub-folders were auto-updating, but others were not. This made me suspicious that there were properties unique to folders that could be tweaked.

So I right-clicked and selected "properties" on the each sub-folder and noticed the following:

  • All the sub-folders that were auto-updating had the "When getting new messages for this account, always check this folder" option checked.
  • All the sub-folders that were failing to auto-update had the "When getting new messages for this account, always check this folder" option un-checked.

So I then made sure this option was checked for all my sub-folders, and then they started behaving themselves.

My only remaining gripe is that the total count of unread messages shown in my desktop's taskbar isn't tallying the total up correctly. It's showing less than what it should. Not sure why as yet...

1
  • 1
    During all these years, I also tried this: I checked every folder in every configured account, but it didn't solve the issue (sometimes, randomly). Some week ago, I completely uninstalled Thunderbird on Windows (even registry keys) and reinstalled it: now the counter gets updated in every folder, even if I didn't put the check on any folder
    – eleftrik
    Nov 14, 2017 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.