15

I have a Parabola (arch)/Linux installation with Kernel 4.9.6. When I insert a usb external hard disk I can see it in lsusb as

Bus 002 Device 055: ID 0411:01de BUFFALO INC. (formerly MelCo., Inc.) External Hard Drive HD-PCTU3 [Buffalo MiniStation]

However I cannot find it as a block device anywhere in /dev. For instance, lsblk returns

NAME              MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                 8:0    0 223.6G  0 disk 
└─sda1              8:1    0 223.6G  0 part 
  └─root          254:0    0 223.6G  0 crypt
    ├─matrix-swap 254:1    0     2G  0 lvm   [SWAP]
    ├─matrix-root 254:2    0 199.4G  0 lvm   /
    ├─matrix-boot 254:3    0     2G  0 lvm   /boot
    └─matrix-var  254:4    0  20.2G  0 lvm   /var

Here sda is my hard disk with some lvm partitions. The usb device doesn't show up in /dev/disk/by-id either. A check at dmesg yields

usb 2-1: new high-speed USB device number 55 using ehci-pci

and nothing else. I can't figure out what is the problem. Could anyone help me out?

26

The most common cause:

You have upgraded the kernel recently, but haven't yet rebooted into it. When you connect a new device, udev tries to load modules matching the running kernel – but you don't have them anymore! Instead your /lib/modules only has files for the installed newer kernel.

Check whether uname -r and pacman -Q linux show different versions; if so, reboot.

  • 1
    Man! Thanks! I spent few hours trying to set up new udev rules and bla-bla-bla and can't understand where is my /dev/sdb! Drivers! It was so easy... – setevoy Apr 4 '18 at 9:27
  • 4
    What if they show the same version? – Berrigan Jun 23 '18 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.