6

I've installed Docker for Windows on my Windows 10 machine, which uses Hyper-V.

Upon opening up a window (either Powershell or regular old command will do) and typing docker run hello-world, I get the following response.

Unable to find image 'hello-world:latest' locally
C:\Program Files\Docker\Docker\Resources\bin\docker.exe: Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers).
See 'C:\Program Files\Docker\Docker\Resources\bin\docker.exe run --help'.

Or, most recently:

Unable to find image 'hello-world:latest' locally
C:\Program Files\Docker\Docker\Resources\bin\docker.exe: Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on 192.168.65.1:53: read udp 192.168.65.2:44376->192.168.65.1:53: i/o timeout.
See 'C:\Program Files\Docker\Docker\Resources\bin\docker.exe run --help'.

As stated in my related questions, Docker for Windows comes with its own apparently unalterable network adapter, DockerNAT. I suppose I need to have that connect to the outside world, but I'm at a loss how to do so.

I've found advice to change to a fixed DNS, which I've already done (8.8.8.8, to be precise). There are no proxies to set.

  • I'm having the same issue, all the workarounds mentioned don't seem to work for me. Did you ever find a solution? – Ingó Vals Feb 11 '18 at 15:34
  • @IngóVals after uninstalling and reinstalling, suddenly it worked. No clue why. May very well be something network or possibly security related, as I'm on a corporate network. – SQB Feb 11 '18 at 15:49
6

had the similar issue.

Solution: Right Klick Docker Icon and go to Docker Settings then Network Tab Change DNS from Automatic to Fixed and Check your Proxy Settings.

|improve this answer|||||
  • Saved my sanity! Thanks. Any idea why this needs to be done? I've now grown weary of docker updates as every update causes things to break and requires tweaks such as these to make it work. – Sudhanshu Mishra Mar 26 '17 at 6:43
0

faced a similar issue, this is because there can be a firewall between your network, if you connect it to direct internet(In my case I connected from my personal hotspot) it will work.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.