0

I am using the vim spell checker. When I do "zg" (Add word to "good" list) it apparently works. If I save and quit ( with :wq command) and re-open the document all words get reddish indicating that they are wrong, except those which were manually added. For example, if I have ten words and seven of then are already ok, then I add the other three words to my "ok list" with zg command, if I close and re-open this file all the seven words will be marked as incorrect and only those three will be marked as "good words".

I can see that two new files are created when I do zg for the first time: ~/.vim/spell/pt.utf-8.add ~/.vim/spell/pt.utf-8.add.spl

And it's like vim only sees the above-mentioned files and not the original one, wich is: ~/.vim/spell/pt.utf-8.spl

0

~/.vim/spell/pt.utf-8.add and ~/.vim/spell/pt.utf-8.add.spl are the only files shown in my ~/.vim/spell directory.

Two things I would try first:

  1. Rename the pt.utf-8.spl file. Vim's official documentation indicates that these word list files should have the following generic form: ".{encoding}.add"
  2. Try setting spellfile explicitly using the specifications described in the docs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.