6

I click on Desktop in the sidebar in Finder, a new tab opens. I click on Applications in the sidebar, a new tab opens for Applications. I click on Desktop again, a new tab opens yet again.

How do I disable this? On Sierra 10.12.

0

Check your Command key is not stuck/held down. When opening folders normally or from the sidebar, if the cmd key is held, the folder is opened in a new tab.

1
  • 1
    I think there's a bug in Apple Remote Desktop where the Command Key is stuck pressed. I closed ARD and reopened again and it was working fine.
    – ninjaneer
    Mar 18 '17 at 2:41
3

This is a long-running bug that Apple have been unable to fix. Still exists even on latest Remote Desktop 3.9.

To recreate the bug, in RD highlight some text say in Terminal or Safari or wherever, and press command+c. Now double click a folder and it opens in a tab. If it doesn't happen then copy some text again and it'll happen the second time.

I found that performing a two-finger right click with the MacBook Pro trackpad temporarily relieves the stuck command key. Neither a mouse right-click or an option click provide the same fix.

Another bug is you cannot hold option and double click the Photos app to launch in select photo library mode. Or iTunes either. The only way to do this on a local keyboard. I think this could be related.

1
  • Holy crap I can't believe this is actually a bug! I was convinced it was a settings issue somewhere and tried everything everyone always suggests and NOTHING made any difference at all, until your answer. Screen Sharing connecting to other machines on my network and sure enough... a 2 finger click fixes the issue, seemingly until the next time a window is opened at which point it starts up again. Super annoying but at least now I know!
    – JVC
    Mar 10 at 2:26
1

It's a bug I was able to isolate it to the particular RDC update. There has been another version but apple did not fix the issue.

0

This happened to me too. Restarting my computer fixed it.

-1

in case someone is still looking for this:

I had the same problem. Tried everything... The ACTUAL option to disable it is in System Preferences -> Dock (yes, Dock)

On the option Prefer Tabs When Opening Documents: set the choices to Manually

-1

The folder opens in a new tab or window, depending on your Finder preferences. In the Finder, choose Finder > Preferences, then click General. Select “Open folders in tabs instead of new windows” to have folders open in tabs; deselect it to have folders open in windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.