1

Background

I am running a Windows Server guest on a Windows host, using Virtualbox. Up until very recently this guest could browse the internet perfectly fine. However, since today, the guest can only access the internet for a minute or so after switching to Bridged Adapter as "Attached to" under Network settings for the machine. After that, the connection just drops and the guest can no longer access anything.

To my knowledge, I did not change anything in the Virtualbox settings previous to this as I've been happy with the way things have worked (and I'm not very familiar with this stuff either). As stated below, I updated my Virtualbox version in an attempt to solve this, but it didn't work. The previous version I had (I'm unfortunately not sure which one) I used for a long time before these problems started to occur.

Configuration

  • Host: Windows 8.1 Enterprise
  • Guest: Windows Server 2012 R2 Standard
  • Virtualbox: 5.1.18. r114002
  • Host uses Wi-Fi for internet access
  • Guest is configured to use Bridged Adapter (under Network --> Attached to), with the name Intel(R) Dual Band Wireless-AC 7265

Symptoms

I have ran ipconfig /all on the guest, and compared the results from when the guest could access the internet and when it couldn't. Here's the diff for Ethernet adapter Ethernet:

                                Working                     Not working
IPv4 Address                    10.0.2.15(Preferred)        Does not exist
Subnet mask                     255.255.255.0               255.255.0.0
Autoconfiguration IPv4 Address  Does not exist              169.254.68.254(Tentative/Preferred) 
Lease Obtained                  March 17th 2017 12:37:41    Does not exist
Lease Expires                   March 17th 2017 12:37:41    Does not exist
Default Gateway                 10.0.2.2                    No value
DNS Servers                     208.67.222.222              fec0:0:0:ffff::1%1
                                208.67.220.220              fec0:0:0:ffff::2%1
                                216.55.96.166               fec0:0:0:ffff::3%1

At the moment I can't ping (pinging e.g. 8.8.8.8 results in "PING: transmit failed. General failure"). However, when I was trying to solve the issue earlier today I was able to ping DNS servers such as 8.8.8.8. I could not ping web servers though.

Access to the internet using Wi-Fi on the host works perfectly.

Google Chrome reports an DNS_PROBE_FINISHED_NO_INTERNET on the guest.

Unsuccessful attempts

  • Upgrading to the latest Virtualbox version
  • Changing to all the other possible options under "Attached to", but Bridged Adapter is currently the only one that gives me at least a little access. I'm quite sure I've used NAT successfully before, though.
  • In Virtualbox-wide settings, under Network, I added a NAT network and used that as "Attached to" for the guest, both with and without DHCP enabled.
  • In Virtualbox-wide settings, I tried both Auto-detect and Direct Connection under Proxy.
  • Tried with and without VPN on the host.
  • Rebooted both the host and guest several times
  • Added Google's DNS servers (8.8.8.8 and 8.8.4.4) (I didn't have to do this before this issue occurred, though) on the guest.
  • Disabled and enabled the Ethernet adapter on the guest.
  • Ran ipconfig/flushdns on the guest.
  • Read questions here on SuperUser regarding this. I have not been able to find a duplicate where internet works a short period of time however, as they all seem to be dealing with no access at all.

Questions

  • Why does internet access only work for a very short time on my guest?
  • What do I need to change in order to get consistent access?

I'm not very good with this, please let me know if there's any other information or more configuration that I should provide.

  • Something on the network you are bridging to detecting multiple MACs behind a single port and killing off access for one of them? – ivanivan Mar 17 '17 at 12:54
  • @ivanivan That might be the case. If so, what can I do about it? Can I change the MAC of my guest, for example? – HenricF Mar 17 '17 at 13:29
  • No, this is a security measure that managed switches, etc. have in them... if required for your work, talk to your IT department. if this is at an apartment complex, etc, talk to the IT support folks – ivanivan Mar 17 '17 at 13:35
  • Change your guests os adapter to NAT, bridging to WiFi is a known issue in many cases. – acejavelin Mar 20 '17 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.