6

So I have this small box display in Chrome

<div style="width:100px;height:100px;background:red"></div>

But it's in fact 130px big. Chrome is scaling all web because of my 1080p monitor.

Example 1[1]

How to disable it? It's only annoying when you are developing websites.

Example 2

7
  • 1
    Definitely not zoomed in? (Hit Ctrl+0 to be sure)
    – Jonno
    Mar 17, 2017 at 15:15
  • Issues specific to programming and software development are off topic, see On-Topic. Try Stack Overflow but please first read How do I ask a good question?.
    – DavidPostill
    Mar 17, 2017 at 15:16
  • 2
    @DavidPostill this is not about programming this is about user application setting. I don't want browse to scale my webpage that's all. Have you read "How do I ask a good question?" ? My question is plain simple. Chrome is scaling websites because of high DPI monitor. Question is regarding computer software not programming.
    – Peter
    Mar 17, 2017 at 16:03
  • @Jonno yes. I think this what chrome does on high DPI devices
    – Peter
    Mar 17, 2017 at 16:07
  • Try to start Chrome with the parameters --high-dpi-support=1 --force-device-scale-factor=1 or /high-dpi-support=1 /force-device-scale-factor=1
    – harrymc
    Mar 20, 2017 at 18:10

1 Answer 1

4
+200

Since Google Chrome version 54, it now detects the DPI settings on the computer and scales the web browser accordingly. Previously, Google Chrome did not pay attention to the system’s DPI settings, but now it does and that is the root cause of the large interface issue.

If the DPI is set to more than 100 percent in the system, this would give the effect of "zoom-in". In most cases this is what an end-user would wish, but not a Web developer.

To force Chrome to ignore the system DPI setting, the solution is to launch Chrome with one of the following parameters (there are two possibilities depending on the Chrome version and OS):

  • /high-dpi-support=1 /force-device-scale-factor=1
  • --high-dpi-support=1 --force-device-scale-factor=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.