0

My initial setup was: D1: 128GB SSD GPT -> Grub2 D2: 128GB SSD MBR -> Windows 10 Bootmgr (Note: both SSDs are identical.)

I installed a beta version of the Debian-based OS on the GPT disk, this time as UEFI. After that GRUB2 didn't manage to add Windows 10 to its menu. Since this is likely to be some issue with the UEFI setup and I wanted to do a new installation of Windows anyway, I decided to convert D2 to GPT and install Windows 7 in UEFI mode on this disk.

Now everytime I boot up Windows 7 setup from my thumb drive (DVD won't start at all) the installation stops, when it is right about to start copying the files from flash drive to hard drive. Showing: Windows installation encountered an unexpected error. Verify that the installation sources are accessible, and restart the installation. Error Code: 0xC0000005

I tried so many things.. Rufus, many many times, with different settings, checked checksum of .iso, changed many BIOS settings back and forth, and I tried many other things over hours and hours and hours and hours... Each time the same error code. I even changed the USB flash drive at some point to be sure, that it was no hardware failure.

At some point I even gave up and just grabbed the Windows 10 again out of despair. As if all this wasn't enough, even the Windows 10 Setup spit out some error, when trying to install. It wasn't the same one but it happened at the point when the setup was right about to start copying files, too.

My SSD was checked several times, it works perfectly fine. Memtest86+ did several passes too, 0 errors. I really don't know what to do anymore. It is as if my BIOS wasn't EFI compatible when trying to do use that feature with Windows. It is clearly a 100% UEFI-bios (from ROG), though.

My question: how do I manage to install Windows 7 in UEFI mode on the second GPT disk?

1

Wow. Just wow.

So I started gParted because I wanted to check my partition setup, which is totally unrelated to above problem. The drive I wanted to check is /dev/sdd, which means I had to scroll through the hard drives in gParted to get there. Luckily my first HDD /dev/sda showed up first in the list and showed me the magic of Windows. The first HDD /dev/sda, which was 100% unrelated and unselected during the Windows installation process was spammed with about 20 separate partitions each labeled alternating with System and Recovery. I deleted all those, rebooted and disabled all SATA controllers in the BIOS except the one that is connected to /dev/sde, which is the drive I wanted Windows 7 to install on. Everything works flawlessly now. Apparently Windows can't handle a machine that features 6 or more HDDs.

This is the magic of Microsoft.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.