I have a 2012 Retina MacBook Pro running Arch Linux with GNOME. Normally, I listen to music using the analog audio I/O interface -- the 3.5mm socket.

Recently, I had to attach a USB microphone to the laptop. While doing that, I used the microphone's built-in 3.5mm socket to monitor the sound I was recording with lower latency and less distortion than what the laptop's internal amplifier, and the backing software, would produce. Because of this, I went into GNOME's sound options and updated the audio output profile to digial, which allowed me to pipe system sounds through the mic and into my headphones while I was monitoring the audio received by the microphone.

After switching back to using the 3.5mm socket on my laptop and reverting the audio output profile to analog (the only option available without the mic), the outputted audio's really distorted. After some tinkering using the ALSA mixer and reproduction of the issue on the laptop's main speakers, I've concluded that the issue is that outputting audio to my headphones now results in the bass part of the spectrum being cut off completely, resulting in a tinny, distorted, and almost downsampled effect.

Unfortunately, I haven't found any settings allowing me to tweak the bass response for the 3.5mm out.

Where can I do this system-wide?

  • What sound server/driver are you using, alsa or pulseaudio or something else? Tried restarting it? – Xen2050 Mar 18 '17 at 8:19
  • @Xen2050 I'm running pulseaudio, but this issue has been persistent across machine reboots. – Jules Mar 18 '17 at 19:32
  • Ah, I thought it was only right after removing the USB device... Does it still happen when running a live ISO, or another OS? If it does, that would indicate a hardware problem. Or if it doesn't, then some configuration problem only. – Xen2050 Mar 18 '17 at 20:12
  • The issue seems to persist when playing music from Fedora 25 with a default-config GNOME under VirtualBox, but I'm not convinced that this is a hardware issue. – Jules Mar 18 '17 at 20:49
  • 2
    Maybe it's a hardware issue? Have you tried another headphones? Sometimes I have the same issue when jack is not plugged all the way in. – konradmb Mar 24 '17 at 18:18

Perhaps a simple solution would be to use pulseaudio-equalizer. It'd allow you to boost the bass a bit.

However, it seems to me that this is a driver/PulseAudio issue, and the workaround would be to grab the equalizer with Pacman:

sudo pacman -S pulseaudio-equalizer.

I'll fiddle around on my machine to see if I can reproduce something similar to figure it out. I'll reply if I work it out.


I had exactly this issue when running Gentoo on my Broadwell laptop - all the music was tinny, scratchy and oversampled. It turned out that, for whatever reason, I had to use PulseAudio instead of ALSA. Switched over to that and audio's been fine ever since.

  • Thanks for contributing, but given that I no longer have run Arch (let alone with the same specific state) I can't validate your solution and accept the answer. Hopefully it'll still be helpful to other readers! – Jules Nov 14 '18 at 2:57

I had an similiar issue and fixed it using pavucontrol. There you can specify many settings for PulseAudio. For me I used the HDMI output and afterwards there was no sound on the 3.5mm socket. Try some time to get the settings right.

  • Thanks for contributing, but given that I no longer have run Arch (let alone with the same specific state) I can't validate your solution and accept the answer. Hopefully it'll still be helpful to other readers! – Jules May 22 '19 at 14:22

This is an engineering problem with the headphones themselves

I've had this problem before and it has nothing to do with the program. Simply put the problem you are experiencing is common with cheaper headphones and apple earphones for the reason that the headphones are defective from wear on the aux cords transmitter rod. Just turn the transmitter rod inside the aux input slightly when you hear the distortion until you can hear it and you should be fine. It's not a permanent fix though.

if that doesn't work keep reading

Worst case scenario

One of the internal speakers is broken...there isn't a fix for that because of how delicate the structure is. If that's the case then just buy a new pair. You'll be able to tell if its that because instead of hearing complete distortion you'll notice the bass is gone for the reason that headphones work together instead of separately. (Closed circuit) If one speaker breaks (I'm referring to the thin metal film you see if you remove the front cap. DO NOT TOUCH IT without a proper tool otherwise you'll break the external hardware further) by a small out of place crease (if you see it flattened you have no hope in fixing the output) or tear then there isn't a way to fix it without a poker. (the screwdriver type tool known for unscrewing stripped screws.) Just use the screwdriver to gently flip the little tin piece you might see folded over. The film is where most of the output coding is so there's no guarantee that it will be that easy to fix because it's still torn.

The easiest thing to do is buy a new pair and reverse the internal programming you did to try to 'fix' it.

  • This was not a hardware issue with the headphones. I've been using them since this issue came up (and still do!), and they're perfectly fine. – Jules Nov 30 '18 at 5:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.