0

I just found out that you can set a key combination to open a particular shortcut on your desktop. However, when I do this, it takes four to five seconds to open, consistently. How do I make this delay go away and make the shortcut open instantly?

For anyone wondering, the way to set the key combination is to right click the shortcut, select properties, go to the shortcut tab and set the Shortcut key property by selecting the field and pressing a key.

It seems you can only use ctrl+alt+key to open shortcuts, but I don't find that to be a problem.

  • Does the program open slower than not using the shortcut key? – DavidPostill Mar 18 '17 at 15:15
  • Yes, if I click the shortcut it will open faster. Also, I'm not using it to open a program, I'm using it to open a folder. – ProgramGamer Mar 18 '17 at 15:19
  • 1
    Not that it is particularly relevant, but opening a folder is running a program (explorer) – DavidPostill Mar 18 '17 at 15:20
  • Right, but I thought it might exclude the possibility that the delay was caused by the program itself. – ProgramGamer Mar 18 '17 at 15:25
0

When you press the key combination, explorer will query all opened windows to check if one of them has this shortcut associated (so it can give the focus to this window) So, if you have a frozen window/program, explorer will wait for an answer until the ~4 second timeout is reached, and then give up.

It's explained by Raymond on this blog: https://blogs.msdn.microsoft.com/oldnewthing/20120502-00/?p=7723

  • 1
    Thank you, this answers the question nicely! Now I just need to figure out which open window causes this haha! – ProgramGamer Mar 18 '17 at 21:02
-1

Disable the SysMain service and reboot. This service sounds very important but it is not. It will solve your problem like magic. God knows why.

  • What does this service actually do? What leads you to believe it will solve OPs problem? – music2myear Sep 10 '20 at 1:27
  • What it does is easy enough to look up. (It used to be called SuperFetch if that helps.) All I know is that in using Windows for the last decade, every time this service is running all of my desktop shortcut keys have a 2-second lag before the program actually starts. Disabling the service and rebooting fixes the problem immediately. Go ask Microsoft why this is. Once in a while MS will push a large update which turns the service back on. Sure enough, my shortcuts all become laggards again, until I do this tweak. – tom Sep 11 '20 at 2:11
  • All that needed to be in your answer. Use the EDIT button and put it there. – music2myear Sep 11 '20 at 3:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.