2

Windows 10 forced me into an update on Thursday evening and everything seemed to go off without a hitch. Or so I thought. I did notice at the time that for some peculiar reason Intel HD Graphics drivers were now being used in place of the GeForce 940M instead of the NVidia drivers. So today (Saturday) I reinstalled the NVidia drivers and everything was working fine again.

I had some video to re-encode with Handbrake today and after about five minutes I noticed that the noise from the CPU fan didn't kick in like it usually does. So I had a look at the 'Resource Monitor' and it averages around '60% Maximum Frequency' which I thought was very odd because it's almost almost around 100% when using Handbrake every single time.

Stranger still I launched the Intel Extreme Tuning Utility and it says my quad core i7 CPU frequency is 1.61GHz currently running at instead of the usual 2.60GHz like it always is when rendering video. It also said the thermal throttling wasn't active.

Believing it is likely all these issues were tied to the Windows 10 Update, I thought my best approach was to do a system restore, but again for some peculiar reason it won't let me roll back any further than today. So I'll never find out if the Windows 10 Update is truly the cause that way.

Has anyone else encountered this problem or have any advice on what I can maybe do to restore the 40% processing power I seem to have lost? I've gone into the 'Power Options' in 'System Settings' and set everything to 100% yet it makes no difference.

  • No; it absolutely is not responsible for the CPU throttling – Ramhound Mar 18 '17 at 23:45
  • Check if you have the new "Game Mode" enabled, maybe that is breaking it for you. – Stan May 15 '17 at 19:42
-1

Yes Windows 10 update absolutely is responsible!...And I haven't been able to fix it either specifically when encoding video through Handbrake. Windows introduced a concept called "Power Throttling" at both a system level and on an app by app basis. Basically, so as to help improve battery life, this lets Windows automatically determine which apps are running in the foreground and which should be placed in the background. Performance limits are imposed on apps in the background to limit their drain on the battery when not in immediate use. However, this is ruining my nightly video encodes, as it is taking more than 3 times as long, since it is limiting Handbrake to functioning at approximately 1/3 capacity. As long as I am using Handbrake actively, encodes occur at full pace, but as soon as I leave the computer alone for a few minutes, Handbrake is throttled. It resumes full capacity if I change the Windows power plan to another and back, but only while I am actively using Handbrake.

I have tried all avenues to deactivate this for either the system at large or for the Handbrake program specifically. I include what steps I have taken in case it helps someone else, but I have not been able to stop Windows interfering with the throttling feature.

- System Level

  • Click on battery icon in system tray and drag new slider to "Best performance". This is supposed to turn all "Power Throttling" off.
  • One can also, supposedly, deactivate "Power Throttling" through Group Policy

    • Click [Win] and then type "Edit group policy"
    • Navigate to Computer Configuration -> Administrative Templates -> System -> Power Management -> Power Throttling Settings
    • Open Turn off Power Throttling and select Enabled to turn it off for all apps.

- App Level

  • Go to Settings [Win]+[i] -> System -> Battery -> Battery Usage by App

  • Locate "Handbrake" in the list and deselect "Let Windows decide..."

protected by Community Mar 17 '18 at 3:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.