0

My macbook pro retina was working perfectly fine up until last night. I put it in sleep mode at around 11% battery left thinking I'll charge it tomorrow.

Approx 12 hours later it won't turn on at all.

I plugged in the charger and let charge till the light went green but it's not turning on.

I've tried and smc reset but still no luck.

It doesn't have a battery pack.

  • What do you man it "doesn't have a battery pack?" Can you clarify? If you press and hold the power button for 5 seconds, then try again, does it boot? – Allan Mar 22 '17 at 1:59
  • It doesn't have a battery. I've held it in for ages. It seems to be dead – Master Yoda Mar 22 '17 at 7:50
  • Still confused. Does it have a battery in it that doesn't hold a charge or is there physically no battery? If the latter, how can it have 11% charge? – Allan Mar 22 '17 at 9:59
  • There is no removable battery. There is an internal battery but no removable battery pack – Master Yoda Mar 22 '17 at 10:00
  • What model Macbook Pro? – Allan Mar 22 '17 at 10:02
0

The SMC usually helps in situations like that, but you might try some of the other boot commands. I've had different ones fix various problems randomly.

  • Hold Shift on boot - Safe mode
  • CMD+V - Verbose mode
  • CMD+R - Recovery mode
  • CMD+P+R - Reset PRAM

Start by holding the power button for 5 seconds to make sure it is fully off before each command.

I'd also connect a display to it and see if you get any feedback.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.