1

Hi I have an MSI z270 SLI PLUS MoBo with an i7 Kaby lake CPU, 240GB SSD (with ubuntu installed in SATA1) and 1 TB HDD (with win10 in SATA 2). Currently if I push the power button W10 will boot. I can hold delete to boot into BIOS or F11 to boot into the menu with all the boot options. This displays my external harddrive, ubuntu, bios, win10, (and I believe a win8 install that is no longer relevant).

What I am trying to do is make it so that the default option I see is the GRUB loader (with all the same options) without holding any key. Currently I launch into GRUB after F11 boot menu selection of "Ubuntu". This is so I can select W10, BIOS or Ubuntu there (in GRUB) every time the computer boots without accidentally booting directly into W10 like I am now.

I also wish to maintain the option for delete to launch BIOS on boot in case anything goes wrong. Thanks for your help.

I have tried changing boot order in BIOS, tried editing with e from GRUB, and tried tutorials using the W10 OS and Ubuntu OS all with no luck so far.

Here is a picture of my partition scheme, as I suspect this may be part of the problem. Partition scheme The Ubuntu GRUB loader is a partition on my SSD, but the windows boot launcher is on my 1TB (Accidentally). I suspect getting them both onto the SSD would help my problem. I have deleted the Win8 Boot launcher (which was also on the HDD as I suspected). After finding this thread Why does GRUB load after I select my Ubuntu Partition from Windows Boot Manager? I have tried downloading easy BCD but it gives me the "device in UEFI mode" error and disables many functions. When I boot into SSD it says missing drivers but I can boot into GRUB on the SSD by selecting Ubuntu on the bootlader menu from within BIOS still (after holding F11). Any suggestions or requests for clarification would be extremely appreciated at this point.

  • boot into ubuntu, run efibootmgr and update the question with the results, please. (no sudo or arguments, we just want to inspect the current boot order.) – quixotic Mar 20 '17 at 19:56
  • Boot options are windows boot manager on the hdd, ubuntu on ssd, then sata 1 ssd, sata 2 hhd, backup external hdd and then enter setup. This is when holding f11 on boot. Efi results are as follows: boot order 0000, 0001, 0002, 0003, 0004. 0 is windows boot manager, 1 is ubuntu, 2 is hdd, 3 is usb hdd – RGordon Mar 20 '17 at 22:10
  • I went ahead and tried to run sudo efimanager -o and changed it to 0001, 0000, 0003, 0004 and it returned "malformed boot order 0001," dropped the commas and got a return where it now says boot order 0001 0000 0001 0003 0004 – RGordon Mar 20 '17 at 22:20
0

Answer comes from quixotic and a tutorial I found copied as follows:

Step 1. run efibootmgr in terminal on ubuntu (simply type: efibootmgr)

Step 2. Identify the boot order from the output (in my case it said ubuntu as 0001 windows as 0000 and then the disks as 0003 and 0004. All were labeled clearly.)

Step 3. Run (with desired boot order based on returned info from step 1 in place of my results): sudo efibootmgr -o 0001 0000 0003 0004

**NOTE -o is a lowercase letter o not 0 or O.

Step 4. Exit Terminal. Reboot. Everything should work.

I was able to make the boot order appear as 0001 0000 0001 0003 0004. I am not sure why 0001 is listed twice, but GRUB is my primary loader now without holding any hotkeys at which point options for Ubuntu, W10 & BIOS are displayed. Also it skips the Windows boot manager completely when selecting Windows.

Source: https://askubuntu.com/questions/485261/change-boot-order-using-efibootmgr

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.