3

I am running on macOS Sierra and I am trying to configure auto-mount of external server's directory via SSHFS and osxfuse. However, every time the disk is being mounted, it is owned by root and normal user does not seem to have access. I have downloaded the latest stable release of osxfuse version 3.5.5.

I have been looking for a solution for couple of hours and none of them did not help. I have already tried setting the allow_other to 1 via

sysctl -w osxfuse.tunables.allow_other=1

However it returns an error

sysctl: unknown oid 'osxfuse.tunables.allow_other'

Note: when I try to simply mount the disk via

sshfs -o IdentityFile=/path/to/key user@host:/path/to/external /path/to/local

This works as expected. The problem occurs when I am trying to configure auto-mount of the same directory. I have also found a tutorial which instructs to create a plist which loads osxfuse, however it uses a path /Library/Filesystems/osxfusefs.fs/Support/load_osxfusefs, whereas all I can find is /Library/Filesystems/osxfusefs.fs/Contents/Resources/load_osxfuse. And even if I replace those values, nothing changes.

Any advices?

3 Answers 3

1

In current versions of OSXFuse and mac OS, the name to use for sysctl seems to actually be "vfs.generic.osxfuse.tunables.allow_other". So the command would be:

sysctl -w vfs.generic.osxfuse.tunables.allow_other=1

Same with "vfs.generic.osxfuse.tunables.admin_group", which might also be of interest to you. It allows you to give allow_other rights only to a specific group, which offers more security. The wiki on this also uses the wrong commands, but the info is still relevant.

0

I haven't been using a mac for a while, so I hope this will help:

I created the place to mount the volume in /media/my_mountfile, and change the permissions for it to be available for every user chmod 777 /media/my_mountfile. Then I added sshfs command directly into my ~/.bashrs or ~/.bashprofile. To achieve this, you must exchange rsa keys between both computers in order not to need a password when connecting with ssh or sshfs.

0

I know it's a bit late, but you just need to add an option to sshfs defer_permissions. Mine worked straight out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .