1

I recently had my work laptop installed with Windows 10 Enterprise 64Bit and office 2016 32Bit.

Now when I want to open MS Query from Excel by selecting "Data -> From Other Sources -> From Microsoft Query", the MS Query application launches minimized and Excel hangs for about 10-20 seconds before displaying an alert with:

Microsoft Query could not be started because it isn't installed. You can install Query by running the installation program you used to intall Office or Excel. The Query option is in the Office Tools category.

Usually MS Query displays a dialog to select an ODBC data source but this dialog never comes.

I've seen other computers running with the same Windows/Office image where MS Query is launching with the "Select data source" dialog as it should.

I've tried to running Office repair, remove/add the Query component from the office installation, remove any ODBC drivers that didn't ship with Windows/Office, and updated Excel with all available updates. But still no luck.

Anyone who can point me in the right direction to solve this error?

  • Look in : \Program Files\Office` for MSQUERY.EXE` or MSQRY32.EXE (you can search for MSQ*.EXE). If you don't find it, rerun Office Repair, Check "Data Access" the "MSQUERY". Let me know if it's enough or not! ;) – R3uK Mar 21 '17 at 12:42
  • I've already run the Repair several times, with no luck. Even tried to first remove Query from the Office installation and then add it again :) What do you mean by 'Check "Data Access" the "MSQUERY"? – bwedel Mar 21 '17 at 13:00
  • My bad, my head was somewhere else when I commented apparently! I meant exactly what you did, so not Office Repair, but Office Installation->Office Tools->MS Query... Did you find the file MSQ*.exe? Tried to execute it? – R3uK Mar 21 '17 at 13:05
  • Quite OK :) MSQRY32.EXE is there, and I can execute it without any problems, it's only when lauching it from within Excel the problem occurs :( – bwedel Mar 21 '17 at 13:10
  • 1
    Thanks for trying, I've depleted my internet search skills on this topic as well :) – bwedel Mar 21 '17 at 13:58
0

Finally I could fix it. There was a problem with Windows Update not installing new updates (error 0x8024401c). I edited the registry according to this https://appuals.com/windows-updates-error-0x8024401c/ :

  • Press Windows Logo key + R to open a Run. Type regedit into the Run dialog and press Enter to launch the Registry Editor.
  • In the left pane of the Registry Editor, navigate to the following directory: HKEY_LOCAL_MACHINE > Software > Policies > Microsoft > Windows > WindowsUpdate
  • In the left pane of the Registry Editor, click on AU under WindowsUpdate to have its contents displayed in the right pane.
  • In the right pane of the Registry Editor, locate and double click on the registry value titled UseWUServer to modify it.
  • Replace whatever is in the registry value’s Value data field with 0 and click on OK.
  • Close the Registry Editor.
  • Restart your computer.
  • Once your computer boots up, launch Windows Update and check for updates for your computer. Windows Update should now not only find but also successfully download and then install all available updates for your computer.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.