I have some applications that I open from time to time, and I always get this UAC message with

Do you want to allow the following program from an unknown publisher to make changes to this computer?

Is there a way I can mark a single program so that won't ask me that again? Like, I think it is good that it asks me the first time, but some programs I do launch more often, and I am ok with them making changes and don't want to be asked all the time.

  • 1
    Bypassing the UAC dialog would give crackers (if they find an exploit) a way to run privileged programs without your explicit permission or confirmation that you intended to run the program. – Joe Internet Mar 12 '10 at 12:05
  • 3
    Honestly don't get why there is no "[x] Always run this program elevated" on the prompt, that would actually make this feature usable... – RomanSt Apr 12 '11 at 20:10
  • 3
    @JoeInternet, you’ve missed the point, Svish was asking about program he does want to run. – Synetech Nov 27 '13 at 1:39
  • After every windows 7 install I always find myself coming back to this issue. Eventually I always end up disabling UAC - which people agree is a bad idea. – AnnanFay Nov 30 '17 at 3:33

There is no way in windows itself to "whitelist" certain applications. You could use the program "tweak uac" to switch really easy and quick between uac settings.


You could also right click the icon/program you want to run and "run as administrator" it should only ask you once in uac that way.

Other option is to completely turn off uac, but it's not reccomended by microsoft nor by me.

| improve this answer | |
  • Yeah, whitelist was the word I was looking for. But alright. I am only asked once either way, so running as admin and such wouldn't make any difference really. But at least now I know kind of :) Turning it off is not an option for me either :) – Svish Mar 12 '10 at 13:21

A trick is to use the Task Scheduler to launch the application:

Create a task for your application in the scheduler (Win+R, taskschd.msc) and launch it with schtasks /run /TN "name of your task" (or use one of the scheduler parameters)

For more info - TechRepublic:

Run UAC restricted programs without the UAC prompt

Make Vista launch UAC restricted programs at startup with Task Scheduler

| improve this answer | |
  • Interesting solution. Although a bit too sneaky for me I think :p – Svish Mar 12 '10 at 13:21

The following worked for me:

  1. Right-click on the link to the program
  2. Click Properties
  3. Select the Compatibility tab
  4. Click Change settings for all users
  5. Under Privilege level, make sure that Run this program as an administrator is NOT checked.

Then if a program ever does need to run with administrator privileges at some time the UAC gives me the option when I try to run it, without having to give permission every time.

| improve this answer | |
  • 4
    Checked or not checked, doesn't seem to make a difference =/ – Svish Aug 26 '10 at 20:05
  • This will not do anything, If a program really needs "Administrative privileges" it can't do anything without it – Anwar Oct 30 '14 at 11:18

I had used Irfanview for years without problems, then something happened and it asked me UAC permission every time - very annoying! I re-installed etc with no luck.

Then I found that this worked for me:
1. Right-click on the link to the program
2. Click Properties
3. Select the Compatibility tab
4. Untick "Run this program in compatibility mode for...[Windows XP SP3]"
5. Click OK

Then it no longer asked me for UAC permission every time! Hurrah!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.