I read the many tutorials on how to tunnel traffic via putty and configure Firefox to access web via that tunnel (Windows desktop). The steps are simple: (A) set connection with dynamic ssh-tunnel at port, say 1010. (B) configure Firefox to use Socks5 at localhost:1010.

This solution used to work for me in the past, but for some reason does not work anymore. I get a page saying "The connection was reset... Try again"

To diagnose the problem, I downloaded curl utility for windows and then run this from command line: curl -socks5 localhost:1010 www.google.com

It returned a valid HTML code of that page. So the problem is not at the putty side, but rather something in FF.

I also tried the solution proposed in here using chrome and didn't manage to get it work.

Does anyone has idea how to solve this out ?

EDIT: relevant screenshots stored here



  • how did you set it up? Post a screenshot or something. It is impossible to answer if we don't know what you set up.
    – Jakuje
    Mar 21 '17 at 20:16
  • Did you try unchecking "Proxy DNS when using socks5" on ff ? Mar 22 '17 at 23:47
  • Tried that as well. no success. This is quite weird since the curl test proves that the tunnel is set up correctly and can bring in web pages. So, this is something in the FF/Chrome app layer that prevents it from using the tunnel correctly.
    – Moshe
    Mar 24 '17 at 12:48
  • Can someone guide me how to debug this problem using wireshark? What should I be looking for in the messages going in and out the tunnel ?
    – Moshe
    Mar 31 '17 at 8:48

Your Socks proxy seems to work fine (PuTTY configuration equals ssh -D 1010 and your curl test also succeed). Your browser configuration (SOCKSv5 to localhost:1010) seems ok, too.

If you are using some kind of virus protection that might be interfering with the browsers connections, try

  • disabling virus protection plugins from Firefox
  • using high source ports (1024 < x < 65536) instead of low port 1010
  • I tried with port number 8787 and receives the same behavior. Firefox has no add-ons/plugings. I simply downloaded latest version from web. I also tried to disable windows firewall and so success.
    – Moshe
    Mar 22 '17 at 11:10
  • Any idea how can I debug what is wrong in my setup ? I have no clue of what went wrong...
    – Moshe
    Mar 23 '17 at 10:17

The problem is more probably with your proxy settings than with Firefox, because the way you test it with Curl is not valid and will succeed even when the proxy is off. The correct command is either curl --socks5 localhost:1010 www.google.com (note the double dash instead of a single one) or (more modern style of doing the same thing) curl --proxy socks5://localhost:1010 www.google.com.

You also probably want to pass DNS through the proxy as well, by using --socks5-hostname or socks5h://.

As to speculate on the question itself: It is possible to disable port forwarding on the server, so if you're not the administrator, try to check whether the policy might have changed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.