27

The company I work for wants us to begin using Microsoft Teams however after logging in the page goes into a redirect loop for about a minute, and then finally ends up on this error screen.

D'oh! To open the web app, you need to change your browser settings to allow third-party cookies. I know that I could just open my browser settings (Chrome in my case) and just allow all 3rd party cookies... but I don't want to do that since it would do this for all websites. Unchecking this box does solve the issue, but it's not an acceptable resolution to this issue for me.

Chrome Settings - block third-party cookies and site data

I also know that I can add exceptions to allow thirst party cookies from certain websites. I've tried adding teams.microsoft.com and even just microsoft.com, neither one works and I still get this error page.

Chrome Settings - third-party cookie exceptions

How are you supposed to use Microsoft Teams without allowing every website to add whatever cookies they want to add? Am I missing something obvious here? It's worth noting that I've also disabled my adblocker software for this domain.

  • This would seem to be a web browser issue, no? As such it belongs on Super User. – ale Mar 17 '17 at 14:32
  • This is how Microsoft Teams seems to work out of the box. You have to make local setting changes just to be able to use their website. I'm happy to move the question there if needed, but to me it seems like other might wan to know how they are supposed to visit this website without requiring a browser security hole. – CBarr Mar 17 '17 at 14:33
  • To provide Microsoft Teams feedback upvote this: microsoftteams.uservoice.com/forums/555103-public/suggestions/… – MarcH Aug 23 '19 at 15:28
27

Add a cookie exception for https://login.microsoftonline.com. This worked for me at least.

| improve this answer | |
8

After login you can check in Chrome what cookies it uses. enter image description here

Third party would be: .skype.com and maybe .online.lync.com

If you use IE you might have *.microsoft.com in your Trusted Zone but .skype.com is not and IE/Edge will throw error. (as sites are in different zones)

At the bottom left (click on the guid error code d928....) of your screenshot you can download a log file (to check details what URL are called and what the issue is)

| improve this answer | |
3

I added all 4 entries and teams.microsoft.com is now working in Chrome with 3rd party cookies disabled. Thanks for the posts.

Where to add

chrome://settings/content/cookies under Allow

What I added

[*.]microsoft.com

[*.]microsoftonline.com

[*.]skype.com

[*.]online.lync.com

| improve this answer | |
2

As Ed B has already written it is sufficient to enter the URL https://login.microsoftonline.com.

To distribute the setting in a company you can set the following regestry value:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\CookiesAllowedForUrls]
"1"="https://login.microsoftonline.com"

To use wildcards in the Chrome Application (answer from Tilo), use this syntax:

[*.]skype.com
[*.]online.lync.com

Else the URL can not be entered. However, I did not have to add the two pages

Source: CLICK

| improve this answer | |
1

A workaround seems to be to just skip the web app and download their desktop application instead: https://teams.microsoft.com/downloads

| improve this answer | |
  • 5
    Which works if you're on macOS or Windows, not Linux. – retorquere Sep 24 '18 at 18:30
  • This would open more security holes than adding a browser exception. – James Aug 5 '19 at 9:39
  • @James you're mixing up two completely different things. Downloading one app is a security risk because it requires trusting one company (not any company). This superuser question is not really about security, it's about privacy and not being tracked by ALL websites on the internet. – MarcH Aug 23 '19 at 15:25
  • @MarcH It depends on what the app does, and what access it has. Better to use a fresh (trusted) broswer profile only for this than use an app. – James Aug 23 '19 at 15:37
  • @retorquere Miracles do happen. Now there is a native Linux version. I've just installed it. – luchonacho Apr 8 at 14:21
1

you need to add an exception to chrome for both:

  • [*.]microsoft.com
  • [*.]microsoftonline.com
| improve this answer | |
0

On my Chrome 67 on Ubuntu 16.04 I had the exact same message saying that I needed to enable third party cookies. Since on my system these were already allowed this was apparently an incorrect error message.

On my system the Teams website started to work after I removed all locally stored data from Chrome that was related to the teams.microsoft.com website and then pressed the Try Again button.

Effectively I simply did REMOVE ALL under chrome://settings/cookies/detail?site=teams.microsoft.com. If this link does not work for you then use chrome://settings/siteData and search teams.microsoft.com

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.