1

I am using VirtualBox 5.1.8 (and 5.1.18) on Windows 7 with guest Kubuntu 16.04

Set up:

  • Guest has only one network interface with mode = NAT
  • Windows Firewall is Off (all profiles, all interfaces)
  • I have Bromium and Pulse secure installed on host (Windows)

Symptoms:

  • I can ping any IP address on guest. ICMP packets go from VM to Host and onto the network and then back. I tested it using tcpdump on Linux (guest) and Wireshark on Windows (host).
  • I cannot connect to any IP address beyond VM:
    • Whenever I try to connect to any IP address outside VM I get "network unreachable" error
    • tcpdump on guest system shows that default gateway responds with ICMP message "network unreachable" to TCP connection request message.
    • Wireshark on host doesn't show any activity related to connection attempt.
  • Connecting to the same hosts from host (Windows) box works perfectly fine.
  • Bridging instead of NAT-ing works fine for the same guest system (when I set interface mode to Bridged connections work fine.).
  • Installed FreeBSD as guest on the same host and got the same problem (can ping, cannot connect)
  • One of my colleagues has exactly the same set up and it works fine for him.

My goal is to make NAT mode working again.

Tried so far:

  • I tried upgrading VirtualBox to version 5.1.18 -- didn't help
  • Downgrading VirtualBox to version 5.1.8 (last known working version)
  • Rebooting after each re-install and re-configuration of VM
  • Installing fresh VM and installing different OS (FreeBSD)
  • Using "Nat Network" mode

So my questions are:

  • What is causing NAT to drop TCP connections as inaccessible?
  • How can I track down what is dropping TCP connections?
  • How I can get NAT working again?

I cannot use bridged mode because I cannot have additional IP address on the network (besides the one I have for my Windows box). So I have to use NAT (or NAT Network)

migrated from serverfault.com Mar 21 '17 at 23:49

This question came from our site for system and network administrators.

  • I am not familiar with Bromium and Pulse secure, but have you tried removing or disabling them? You specifically mentioned them so I am assuming you have some suspicion they are involved in the problem. – acejavelin Mar 22 '17 at 1:08
  • well, note that if NAT is on and working, you would not be able to ping the guest of connect to its services via TCP/UDP, from the Host unless you have configured port forwarding rules. – Frank Thomas Mar 22 '17 at 2:55
0

I had my Windows (host) re-installed and it fixed the issue. Same setup.

  1. Reinstall Windows
  2. Install VirutalBox
  3. Add VM to the VirtualBox and start

It works as it used to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.