1

I am using the Romanian (programmers) keyboard in Windows 10 so that I can insert special characters using the AltGr key (or Ctrl+Alt). All of them work EXCEPT for AltGr+Shift+S (that should insert capital S-comma or Ș). From my understanding so far, this is equivalent to Ctrl+Alt+Shift+S. My thought was that some other program had registered the combination and when I press it, it goes to that program instead.

What I have tried so far, unsuccessfully:

  • searching for hotkeys in the registry using nirsoft's RegScanner - nothing found
  • searching for hotkeys using nirsoft's HotKeyList - nothing found
  • searching for hotkeys using a vbs script from a superuser/stackoverflow post (can't remember which, I've read so many topics)
  • closing all user programs one by one with task manager and trying the hotkey to see if I closed the culprit (though this did not work as well as planned, as some services would keep restarting)
  • rebooting in safe mode did not make it work!
  • using autohotkey to insert the character - nothing happens

Basically the combination seems to be dead. I am not even sure if it registers. On Linux it works fine, and on Windows Ctrl+Alt+Shift + other characters works fine. Ctrl+Alt+S also works fine (without the Shift).

I am running out of ideas. I really thought autohotkey would work, but kept it as a last resort. Strangely enough, autohotkey displayed the following behavior:

  • setting Ctrl+Alt+Shift+S to send the character Ș did nothing
  • setting Ctrl+Alt+Shift+S to do something else (like display a messagebox) did nothing
  • setting some other combination (like Ctrl+Alt+Shift+W) to send the character Ș would actually trigger the hotkey for Ctrl+Alt+Shift+S (so it would display the messagebox I set earlier).
  • setting some other combination to send the unicode for Ș (U+0218) would work!
  • setting Ctrl+Alt+Shift+S to send the unicode for Ș would not work

So for the moment I have it set in autohotkey with Ctrl+Alt+Shift+W since it's above the S on the keyboard, but it's less than ideal. Also, I would really want to find out the cause of this.

0

Did you try the following AutoHotKey definition?

+<^>!s::­Ș

For me, it works nicely, AltGr+Shift+S produces Ș, in line with expectations from AltGr key.

Note: Do not press Ctrl+Alt+Shift+S, it is not the same as the above. For native Windows apps, they are not equivalent.

-1

Using Alt-Ctrl combinations is not recommended. Those can have a wide range of effect in many general use programs.

Use the defaults instead. When you switch language to Ro, those will work: "[];'\" are the equivalent of "ăîșțâ". Shift+those works for the CAPS version.

No need for Alt or Ctrl whatsoever.

4
  • That's the issue, I don't want to use the old keyboard layout because I code a lot. And it's much easier to remember the special characters as AltGr + their non special version. I want to know how to find out which program is preventing the specified hotkey from being issued. Mar 23 '17 at 17:02
  • You can only do that by checking them individually.
    – Overmind
    Mar 24 '17 at 6:55
  • 1
    @Overmind – I find this answer misleading, because it ignores long-year principles of international keyboards supported by Microsoft and also by other platforms. AltGr is their way to type national characters and it is generally equivalent to Ctrl+Left Alt when related keyboard layout is active. Request of the OP is therefore legitimate. Regarding your concern, most apps recognize between Ctrl+Left Alt (as compatible way of pressing Ctrl+Alt) and AltGr which produces national characters. The only "dumb" apps who confuse this are multi-platform ports like for example Eclipse IDE.
    – miroxlav
    Jan 14 '20 at 14:33
  • I find it absurd to try to use 4 keys instead of pressing just 1.
    – Overmind
    Jan 15 '20 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.