2

My laptop has an Intel Core 2 Duo T9300 which should be running at 2.5GHz, however CPU-Z consistently reports my Core speed at right under 1.6Ghz (8x multiplier and ~200MHz Bus Speed). Even when I'm doing heavy development work and the processor is running at 100% for extended periods of time the core speed reported by CPU-Z never goes up to 2.5GHz. My understanding is that this reduction in speed is to save power, but this happens even when I'm plugged into the outlet.

Does anyone know why this is happening or how to fix it?

4

Does anyone know why this is happening

Its called SpeedStep

how to fix it?

There's nothing to "fix" per-se, as and when the load increases, the frequency will bump up.

Also,

Under Microsoft Windows XP, SpeedStep support is built into the power management console under the control panel. In Windows XP a user can regulate the processor's speed indirectly by changing power schemes. The "Home/Office Desk" disables SpeedStep, the "Portable/Laptop" power scheme enables SpeedStep, and the "Max Battery" uses SpeedStep to slow the processor to minimal power levels as the battery weakens. The SpeedStep settings for power schemes, either built-in or custom, cannot be modified from the control panel's GUI, but can be modified using the POWERCFG.EXE command-line utility.

  • Changing the power scheme to "Home/Office Desk" and restarting took care of the problem. Thanks! – Andrew Hampton Mar 16 '10 at 11:22
  • @Andrew Hampton Good to hear! – Sathyajith Bhat Mar 16 '10 at 18:12
1

Check your "Power Saving" settings and choose the "performance" option. And plug your box in.. Most laptops will go into power saving mode automatically when unplugged from wall power.

  • Do you mean "Power Options" in the Control Panel? This is an XP machine. "Performance" isn't an option on the Power Schemes tab, but the speed reported by CPU-Z didn't change after trying a few of the settings there. – Andrew Hampton Mar 12 '10 at 16:07
  • Your CPU may just be idling itself if it's underused. Try running a game or archiving your outlook email in the background while checking the speed. – Chris Nava Mar 12 '10 at 18:13
0

I just had a customer with this problem with an HP-15 machine with Windows 10 installed. The processor speed was actually throttled back to 25% of rated capacity. No SpeedStep available in the BIOS.

After several hours of fiddling around, I deleted "Intel Dynamic Platform and Thermal Framework" from "System Devices" and that fixed the problem. (Note, you cannot delete it from the main "Device Manager" menu...at least I couldn't, but deleting it from the System submenu worked).

  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Aug 29 '17 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.