14

I have a work laptop with Windows 10 x64 Enterprise installed on it. Previously it had Windows 7 x64 Ultimate. I used to be able to control the headphone volume independent of the speaker volume. I generally have the speakers muted but the headphones unmuted. I cannot currently do this, I can't figure out why.

enter image description here

12

My Windows 10 does remember the volume independently with headphones plugged or unplugged, but not the mute state.

When I want to use the speakers, I put some volume (headphones unplugged), either using the systray volume control or the keyboard volume keys.

Then to mute the speakers back, I do the following, headphones unplugged:

  • Starting situation:
    volume-on
  • Drag the volume to zero using the systray control; on reaching zero, it mutes by itself (a cross appears on the volume control)
    volume-muted
  • Click the cross, so that the volume of the speakers is set to zero, unmuted. This is important, because otherwise if I use the headphones, then unplug them, it will play on the speakers. (I assume at the volume set on the speakers before muting them.) volume-zero-unmuted
  • This approach seems to work when my system isn't showing separate controls for speakers and headphones which it's doing right now. Looks like I need another reboot. – Eric Mar 31 '17 at 20:49
13

If this problem persists after rebooting, try the following solution (worked for me on an up-to-date WIN10 Pro):

  1. Find the good old "Control Panel"
  2. Go to "Hardware and Sound"
  3. Open the "Realtek HD Audio Manager"
  4. Click on "Device Advance Settings" in the top right corner
  5. Select "Multi-stream mode" instead of "Classic mode".

That is the trick! The main job is done.

Now right-click on the volume control in the task bar, go to "Playback devices", make sure (if necessary) that all disabled and disconnected devices are shown - check by right-clicking - and then you should see the headphones separated from the speakers. Enjoy!

  • @Facebook Can you download and install it? – Pankrat Oct 19 '17 at 11:35
  • None of the other answers worked for me but this one worked perfectly. Before I only had one playback device listed in my volume control, called Speaker/HP. Now I have a dropdown with a second option called Realtek HD Audio 2nd output which controls my headphones only. Thanks! – Emma Nov 10 '17 at 18:08
  • 2
    This provides a deterministic solution. Others depend a lot on fishy steps and get flushed after rebooting. – DanielCuadra May 8 '18 at 17:44
  • This is exactly what I was looking for. Thank you for the answer @Pankrat – James Jithin Sep 18 '18 at 9:16
  • what realtek audio manager version do you have? – Toskan Aug 10 at 21:55
2

In some cases, the Realtek driver may not provide options to disable "Multi-stream mode" (I am using HP laptop and the software called DTS Audio Control Panel does not)

You can change the audio driver to Microsoft's and it will allow the computer to remember volume for speaker/headphone separately

To change driver, open Device Manager, right click on your audio device, click update device->Browse my computer->Let me pick from a list->choose "High Definition Audio Device". You may need to reboot to apply this change.

0

I rebooted my computer and the Playback settings showed a separate controls for headphones and speakers now.

Separate headphones and speakers

I went to the settings for the speakers and muted them:

Mute speakers

Here you can see my headphones aren't muted:

enter image description here

It works as expected when I plug in my headphones my sound unmutes and it mutes again when I unplug them.

  • Glad to hear that you resolved the problem! Just out of curiosity, during your initial troubleshooting procedures you hadn't already tried rebooting the computer? – Run5k Mar 27 '17 at 17:43
0

i tried every step but didn't work for me. I use Windows 7.

My solution was:

1st - plug the headphone

2nd - choose the volume you want

3rd - in the volume control, click to mute

It disabled the speaker but the headphone continued in the volume i chose.

I hope it helps! ;)

0

Version

enter image description here

  • Open the "Realtek HD Audio Manager"
  • Click on "Device Advance Settings" in the top right corner
  • Choose the second option

enter image description here

Then Use Audio Switcher to quickly change playback devices using hotkeys

protected by Community Aug 14 at 13:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.