I recently unistalled MonoGame but after doing so the templates still remained. I did a search from the explorer and removed the templates from the AppData folder. This didnt completely remove them becuse now I'm left with broken templates in the "New Project" Window in Visual Studio. When I try to create a project with them it says something like "Template doesnt exist, please repair the file" but it gives me no option to remove the broken template from the list. How would I do this?

  • Look in the registry for remnants of the templates.
    – DavidPostill
    Mar 25, 2017 at 13:58
  • @DavidPostill Can you please elaborate? :)
    – VinnieH01
    Mar 25, 2017 at 14:03
  • No as I don't have MonoGames or Visual Studio installed. Typically information about program configurations (templates) is stored in the registry. See Registering Project and Item Templates for more information.
    – DavidPostill
    Mar 25, 2017 at 14:06
  • @Thanks for your help but there were no remnants of the templates in the registry. Any other ideas?
    – VinnieH01
    Mar 25, 2017 at 14:16
  • Unfortunately not :/
    – DavidPostill
    Mar 25, 2017 at 14:19

2 Answers 2


VinnieH01's method is like using a machine gun to kill a fly.

You should rather delete only the ProjectTemplatesCache folder in a whole, which will get rid of outdated templates and nothing else.

The full path would be:

  • 2
    Havent tried it but it should work so I'm accepting this answer instead of mine
    – VinnieH01
    Aug 2, 2017 at 21:45
  • Similar answer at this thread. Jan 1, 2018 at 13:57

I fixed it by clearing the Visual Studio Cache, to do this you remove the contents of the following folder:


Just remember to save your CurrentSettings file since all of your settings will be lost.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .