Recently Chrome has started crapping out after being open for too long or having too many tabs open.

It looks like this:

Google Chrome with the contents of the tab filled with gray instead of the new tab page

So when that happens I switch to using Microsoft Edge. Google then kindly reminds me that I should be using chrome:

"Get to Google faster. Switch your default search engine to Google."

I press "No Thanks", but it comes back. Is there a way for me to prevent this from happening?

  • Btw, the Chrome issue you described is already fixed. There was an update some days later.
    – Aganju
    Mar 26, 2017 at 5:26
  • 2
    Should this be moved to Web Apps? It seems to be more about Google.com than either Chrome or Edge.
    – Stevoisiak
    Aug 29, 2017 at 13:24
  • @Stevoisiak Maybe, but it's arguable as it's a browser related "feature". Perhaps (just thinking out loud) there's a hidden feature / chrome|edge settings or flag to disable this ?
    – deryb
    Dec 9, 2020 at 19:41

6 Answers 6


I believe you're referring to this popup about Chrome (browser), not the one in your picture about Google (search engine).

popup image

I haven't come across a way to simply make Google remember my answer and stop asking me, but you can block it like any other ad with Adblock:

  1. Click the ... in the upper right of the browser.

  2. Click Adblock


  3. Click "Block an ad on this page"

  4. Click the popup and drag the Adblock slider until it disappears

  5. Click "Looks Good"

  • 2
    For this to work, you have to install AdBlock. Aug 29, 2017 at 12:32
  • I tried this and it does not work. They are probably changing the pattern so that it can't be easily blocked using AdBlock. Dec 18, 2018 at 11:20
  • Thought about this too, but for some reason ABP (Ad Block Plus) hangs when using the block selection feature. Then I tried just inspecting and deleting the element, it's fairly easy since it's just an iframe. I guess a TamperMonkey user script would hack this away, but I don't have the time... I went for the user agent switcher extension.
    – deryb
    Dec 9, 2020 at 19:39
  • None of these solution are feasible for a coporate/business enviroment where one is trying to keep a low software footprint. Is really a shame for Google to continue with these insane practices. For now this has to be endured by our users. As crazy as it might sound actually running bing as the default browser to avoid those pop-up and for those that want to use google know where to go .....
    – Odanap
    Aug 9, 2022 at 18:17

Sorry to necro but this came up first when I searched for the problem so thought I'd post my solution.

I found if I disabled my ad blocker, loaded google.com, clicked no, not interested, then re-enabled my ad blocker, from that point forward it stopped asking me. Until I did that, it did it every time I went to google.com. You might have to redo this if you clear your cookies.

  • I'll have to confirm at a later time, but so far (within 1 day of testing) this seems to have worked!
    – Raj
    Feb 20, 2020 at 2:05
  • This appears to work.
    – Rich
    Jun 6, 2021 at 23:05

For Edge try this... Open Edge then click F12. Find the Emulation tab then under Mode open the drop down list named "User agent string". Select Google Chrome.


For Edgers, if you're sick and tired of Google trying to own your life and dictate how you use your browser, and want to circumvent the display of its aggravating Chrome pop- up when using Google to search for whatever and return to your one-click lifestyle, then try the following if none of the other answers work (I've tried all and none work for me):

Click on the menu expansion ellipses (…) in upper right corner

Click on Settings

"Open Microsoft Edge with" and select "A specific page or pages" from selection box

    Enter a URL other than Google (I use https://www.drudgereport.com/) and click
    the disk (save) icon

Scroll down to "Advanced settings" and click "View advanced settings"

    If desired, turn on "Show the home button" and select "New tab page" in the
    selection box

    Scroll down to "Search in the address bar with" and if "Google" is not
    displayed, click on "Change search engine"

        Under "Choose one" select "Google (default)" or "Google Search (discovered)"
        (if a Google option is not displayed, back out of Settings and search for
        google.com, then go back into Settings > Advanced settings > Change search
        engine and select the Google option that is now displayed)

Back out of Settings

NOTE: If you want other Google services such as Gmail, Images, Maps, Translate, and others, and you don't have them bookmarked, enter google.com in the address bar to load the familiar Google splash page (including the infuriating and extremely invasive Chrome pop-up).

Cheers and Ciao Wow


After trying a few DIY solutions (Ad Block, Tamper Monkey), I decided the User Agent switching method was the 'cleanest' and most 'anti big brother' promoting one. Why should Big Tech companies be allowed to care (or scare us) about using an alternative to THEIR browser ?

So anyway, I had to use this extension, since the manual User Agent settings change (the top answer) wasn't sticky (permanent) for me (it resets on each page load it seems ?). Here's this extension:

User-Agent Switcher (Edge Addon)


Hello all Windows 10 users, I Found this solution from another user. It worked perfectly. Here is what you do: Click the windows key + i key. This will bring up "Windows Settings". If not go to the search box next to the windows menu at the bottom left of your screen and type "Settings" excluding the quotation marks.

Once opened, in the "Find a Setting" box at the top, type in "notifications", again no quotation marks. Press ENTER. Select the FIRST option on the right side called "Notifications and actions settings". You should now see another box appear with the title at the top stating that you are in fact in "Notifications & actions".

Now all you need to do is scroll down a little bit, either by using down arrow or by using your mouse. Under the "Notifications" section you will see an option called "Get tips, tricks and suggestions as you use Windows". Toggle this to the OFF position and bingo, no more PUSH notifications from Windows to you regarding installing Google Chrome.

Now this worked for me and I hope this works for all of you too, plus anyone who has come across this. For your information I’m running Windows 10 so access to the above options maybe slightly different in other versions of windows, although I would expect the likes of Windows 8 & 8.1 to be roughly the same.

Good Luck!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .