2

I am using several Linux guest in VirtualBox on a windows 10 laptop.

A week ago the networking in all 6 Linux guests in VirtualBox stopped working. These Linux distros include Debian and Ubuntu variations.

I have a similar setup on my desktop which still works fine.

I compared all the network setting on both computer and they are the same, but on the desktop I have full network access, but on the laptop I can ping 8.8.8.8 but not www.google.com.

I have un-installed VirtualBox and reinstalled, Version 5.1.18 for windows, 3 times on the laptop with no change.

My laptop is a Toshiba Satellite P50t with 16Gb ram and 1Tb SSD hard drive.

I was using Wifi, but I have just connected to Ethernet cable with no change.

I have tried adding nameserver 8.8.4.4 and 8.8.8.8 to resolv.conf with no effect.

Luc

1
  • I had exactly the same problem, so I would like to add one more symptom: Remote desktop to a running VM stops working, even from the host (on localhost). Otherwise thanks to jseguillon, the solution worked for me as well. Apr 3, 2017 at 11:08

1 Answer 1

0

Did you check if a program named "Lavasoft companion" is installed ? This "tool" works for some days but after a period it fails with "CERT_E_EXPIRED" error in your VBoxHardening.log.

You can search for LavasoftTcpService64.dll in your Windows\System32\ directory.

If installed : follow this procedure https://www.adaware.com/forum/index.php?/topic/34376-solution-for-lavasofttcpservice-problem-after-uninstallation/

4
  • Hi jseguillon, That was the problem. as soon as I removed Lavasoft Web Companion, everything works again. That Lavasoft is a pest. Thank you so much for finding this. I spent many hours trying to get this working again.
    – ltheoret
    Mar 27, 2017 at 16:25
  • You should outline, quote, and cite the procedure within the body of your answer.
    – Ramhound
    Mar 27, 2017 at 16:29
  • Hi, What I did to remove Lavasoft Web Companion is: un-install it. the nremoved the Lavasoft...dll fines from both the System32 and sysWOW64 directories found under the Windows directories on drive C:. in those same directories I also removed some Lavasoft..ini files.
    – ltheoret
    Mar 27, 2017 at 23:32
  • Donwvoted why ? This solution clearly helped OP to get NAT working again... I wish i had this solution when I got myself in trouble; it would have saved me from 2 full days of troubleshooting...
    – jseguillon
    Mar 28, 2017 at 7:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.