I know I can prevent a mouse from waking the system from sleep by unchecking "Allow this device to wake the computer". The problem is that if I plug the USB receiver of the wirelss mouse into a different USB port, that setting is lost. I have to uncheck it again.

Is there anyway to prevent the mouse from waking up the computer no matter which USB port the receiver is plugged into?

1 Answer 1


You can use Powercfg.exe tool to disable a device from waking the computer from a sleep state.


powercfg -devicedisablewake devicename

devicename specifies a device retrieved by using the powercfg -devicequery wake_armed command.

Check the following link for detailed information about Powercfg.exe tool: Powercfg Command-Line Options

  • 1
    I also needed this to stop my USB wireless mouse from waking my machine. No amount of disabling the mouse wake in device manager would work. Feb 15, 2018 at 11:42
  • @MerseyViking I had the same problem as you describe and I finally found out that I had to disable my keyboard from waking the computer as well for it to work for the mouse. See answers.microsoft.com/en-us/windows/forum/windows_10-power/…. Jul 18, 2020 at 0:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.