3

I tried asking this at AWS forum and got no help...hoping someone in stackexchange has a solution.


Recently switched my AWS EC2 ubuntu 14.04 instance from using a EBS volume to the newish EFS (expanding file system). That all works great and I moved for example all my owncloud data there.

Now I wanted to move my docker files from var/lib/docker to my efs volume but when I do that and then start up a container I get

Error response from daemon: error creating aufs mount to /mnt/efs/docker/aufs/mnt/1564d0beb71067db05da45cc2777f702026c4c0e62ee8ffbc29bafd9a7d6284a: file too large

This makes me think there is some "weirdness" with EFS volume that it isn't "expanding" when an image is created or attempts to load.

Just for grins I scrubbed the docker folder on the EFS volume and did the same run and got the same error about "file too large"

Just to be sure it's the efs volume I did the same but used an EBS volume and no problems at all....so yea it's something to do with the EFS volume

here is my mount command

mount -t nfs4 -o nfsvers=4.1,rsize=1048576,wsize=1048576,hard,timeo=600,retrans=2 $(curl -s http://169.254.169.254/latest/meta-data/placement/availability-zone).xxxxxxxx.efs.us-west-2.amazonaws.com:/ efs

Any ideas on how to fix it. I suspect docker is trying to make the aufs mount but "sees" the disk as being full instead of being 8 exabytes that linux df reports which is a consequence of being an expandable volume (EFS).

us-west-2b.fs-2338c18a.efs.us-west-2.amazonaws.com:/  8.0E   12G  8.0E   1% /mnt/efs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.