When I try to re-install PowerBI, it won't let me because I cannot uninstall the previous version... what can I do to delete all existing traces of it so that I can uninstall?

I am on version 2.36.4434.381 and cannot find any free way to download this version (so that I can uninstall).

I have tried Revo Uninstaller and it didn't go all the way through so I deleted the registry key for it and now I can't even see it in the list of uninstall...

Now, I think I am stuck... unless I find this specific version...


Have you tried running CCLeaner? The registry clean up tool in it could possibly remove all records of that software since it is no longer installed.


After I forcibly remove the program from the registry, no program was able to see it.

After using the Microsoft Fix-It tool fixed the issue and selecting the option where I had to select that the program does not show, I was able to select the program from a list and a few minutes later... it magically fully uninstalled.

I was then able to just install new version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.