2

I am sure I was able to double click a crash dump file (*.dmp) file in explorer in my old PC and it will open up in WinDbg. In my new PC it doesn't open and gives an error.

Could not create process "c:\my-path\my-crash.exe.dmp". Win32 eror 0x193

%1 is not a valid Win32 application

The error is understandable because it is trying to open the dump file as executable. I need to provide -z flag to windbg to tell it to open it as dump file and I also need to enclose the file path in quotes. I have verified this on command line but how do I configure the double click to do that?

Again I am pretty sure I had this working on old PC that I no longer have.

2
  • You need to assoicate the .dmp file extension with windbg. I do not recomend you do that because windbg supports command line arguments. Its not designed to be associate with a file extension.
    – Ramhound
    Mar 28, 2017 at 20:06
  • @Ramhound I have done that, thats why it opens the dmp file but gives that error because of the reasons you described. But I know I had it working in the past, dont know how.
    – zar
    Mar 28, 2017 at 20:19

1 Answer 1

3

Andrew Richards explained this in his blog, some years ago. Open cmd in your install folder of Windbg and run WinDbg.exe -IA to register the file File Association. You can also use the provided reg file, but here you need to change the paths.

2
  • That did the trick but like the first comment on that post, I saw it was still not working when I ran windbg -IA because I had already manually associated .dmp file with windbg. I had to remove that by deleting the key below in registry editor and that fixed everything! HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\‌​Explorer\FileExts\.d‌​mp
    – zar
    Mar 29, 2017 at 17:30
  • It is documented here as well.
    – zar
    Apr 17, 2017 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.