8

Attempting to activate developer mode so I can access the Linux Subsystem feature. Upon switching to developer mode, I receive the error in the title and am subsequently unable to locate the package in the 'optional features' list where it is supposedly located. The only other suggestions I've seen online involve registry manipulation, which I view as a last resort--is there no other alternative way to access this package?

  • which windows 10 build do you use? – magicandre1981 Mar 29 '17 at 16:15
  • I am using build 14393. Checked for updates yesterday just before trying all this. – user242007 Mar 29 '17 at 23:40
  • try to run this command: DISM /Online /Add-Capability /CapabilityName:Tools.DeveloperMode.Core~~~~0.0.1.0 does this install the dev mode? – magicandre1981 Mar 30 '17 at 15:44
  • It returns Error 87: no Windows features were specified on the command line. – user242007 Mar 30 '17 at 23:24
  • this must be one line. also run DISM /Online /Get-Capabilities to get the correct name of the dev tools – magicandre1981 Mar 31 '17 at 15:37
3

I had the same error - I was able to fix it by changing the value of "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU UseWUServer" to "0". I'm not aware if you are able to fix this without changing this registry value. Any other fixes may be unnecessarily convoluted.

If you absolutely cannot alter your registry then you might want to contact your system admin to resolve this and he will do it for you.

After a system restart the package installed for me.

https://www.kapilarya.com/developer-mode-package-failed-to-install-error-code-0x80004005-windows-10

1

Have you tried this solution on the social forum of Microsoft? https://social.msdn.microsoft.com/Forums/en-US/a7e94e5b-db19-492f-a1c1-d5fa3aa87d0d/enabling-developer-mode-fails-with-error-code-0x80004005?forum=Win10SDKToolsIssues

  1. Open the Settings app.
  2. Select “System”
  3. Select “Apps & features”
  4. Choose “Manage Optional features”
  5. Press the button “Add a feature”
  6. Select the package for Windows Developer Mode
  7. Click “Install”
  8. Reboot your PC
  9. Launch Command Prompt as Administrator
  10. Run: sc config debugregsvc start=auto

Finally, return to the “For Developers” Settings page. You will still see the error code, 0x80004005 but you should now be able to get access to the developer mode specific features.

  • )you forgot the most important parts of the linked suggestion) – Ramhound Mar 28 '17 at 22:55
  • 2
    I have. As stated in the original question, 'Windows Developer Mode' does not appear in the list provided after selecting 'add a feature.' – user242007 Mar 29 '17 at 1:56
  • I also tried this solution but Windows Developer Mode does not appear in the list provided after selecting "add a feature" – Ammar Jul 18 '18 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.