1

I'm running Debian 8.7 and I want to install the unstable package dolphin-emu so I can play GameCube games on my computer.

I followed this answer on Serverfault to change my apt configuration so I can install unstable packages. However, it doesn't work.

$ sudo apt-get install dolphin-emu
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dolphin-emu : Depends: libavcodec57 (>= 7:3.0) but it is not going to be installed or
                        libavcodec-extra57 (>= 7:3.0) but it is not going to be installed
               Depends: libavformat57 (>= 7:3.0) but it is not going to be installed
               Depends: libsfml-network2.4 but it is not going to be installed
               Depends: libsfml-system2.4 but it is not going to be installed
               Depends: libsoundtouch1 (>= 1.9.2) but it is not going to be installed
               Depends: libstdc++6 (>= 6) but 4.9.2-10 is to be installed
               Depends: libwxbase3.0-0v5 (>= 3.0.2+dfsg) but it is not going to be installed
               Depends: libwxgtk3.0-0v5 (>= 3.0.2+dfsg) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

It seems apt-get is refusing to install some dependencies.

How can I make this work?

  • 1
    try apt-get --reinstall install libavcodec57. If its sucessful what version is installed and from what repoistory? – Ramhound Mar 29 '17 at 18:16
  • 1
    @Ramhound Doesn't work, same error with different dependencies. If I follow the first dependencies, then I finally arrive at libstdc++6. When I reinstall libstdc++6 it reinstalls version 4.9.2-10 instead of version 6. – Paul Mar 29 '17 at 18:48
  • 1
    You didn't verify if your using the correct repository. – Ramhound Mar 29 '17 at 18:52
  • 1
    Have you tried installing the stable version of the emulator then upgrading that installation to the unstable version? – Ramhound Mar 29 '17 at 18:56
  • 1
    @Ramhound How do I check if I'm using the correct repository? This is the output: pastebin.com/TESPk4BD The emulator doesn't have a stable version – Paul Mar 29 '17 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.