0

Please do not mark this as a duplicate of set JAVA_HOME in windows but "ant build" still fails

First and foremost, none of the solutions provided in the above question works to my situation with WINDOWS 10.

I have set JAVA_HOME environmental variable on WINDOWS 10 environment, but still unable to use the already set variable through an ANT script. Always get an error that JAVA_HOME environmental variable is not set.

Please check the following screenshot to gain more details about the issue that I'm facing with Java 8 and WINDOWS 10.

enter image description here

3
  • Your PATH variable appears to be far to long. Shorten each instance of say Program Files to its shorten version.
    – Ramhound
    Mar 30, 2017 at 12:04
  • Changed it to no avail! Mar 31, 2017 at 11:15
  • Thanks for the help though, I have a workaround that's working. I'm setting the variable via a batch file before the ANT script executes Apr 4, 2017 at 1:12

0

You must log in to answer this question.

Browse other questions tagged .