1

I have a problem that seems to be the inverse of most others on the internet. I can boot Windows 10 in UEFI mode, but if I disable Secure Boot and enable CSM, I cannot boot Windows 10.

Ordinarily, I would be happy using UEFI, but at the moment I'm playing around with Linux live USBs, which will only show up in CSM mode (they do work in CSM mode).

The UEFI/BIOS settings are set to boot from the SSD first, then USB, then disc (which doesn't exist) and finally LAN.

Even when manually selecting the SSD (which shows up) in CSM mode using the F12 boot menu, the following error appears:

enter image description here

The laptop is a TOSHIBA Portégé running Windows 10 Pro 64-bit.

  • 2
    So I presume, after you have enabled CSM (which means Secure Boot is also disabled), you reinstalled Windows? It sounds like, your disk still is using GPT, instead of MBR. If you are unable to boot Windows it means, your system disk, is still GPT not MBR. So format your HDD, then boot to an installation disk with CSM enabled, that will allow you to format your system disk to MBR and thus allow you to install Windows – Ramhound Mar 30 '17 at 22:06
  • @Ramhound That's what I was suspecting. (And no, I didn't reinstall.) I don't particularly want to reinstall, however. How do I verify that my disk is using GPT? And if I were to reformat, could I still boot MBR in UEFI mode? (I know on one of my previous laptops, Windows would boot in either mode.) – Dog Lover Mar 30 '17 at 22:09
  • Boot into Windows, go to Disk Management, if you have more then 4 partitions it's GPT. If you still can't figure it out, provide a screenshot, of your disk layout. MBR isn't compatible with UEFI mode when your talking about Windows – Ramhound Mar 30 '17 at 22:49
  • @Ramhound I have more than 4 partitions. So if MBR isn't compatible, why would my old laptop have booted Windows in either mode? – Dog Lover Mar 30 '17 at 22:55
  • 1
    Because your old laptop supported a hybrid compatible mode. This meant it could detect both MBR and UEFI and adjust. Your new hardware doesn't, but in neither case, could you have explicitly booted to an MBR disk in UEFI only mode. Windows 10 fully supports MBR, so you would have to format your hdd, to achieve what you want. My suggestion since you only want to use live environments is to leave your hdd alone, and enable/disable CPM has needed, in order to boot to them – Ramhound Mar 30 '17 at 22:59
0

Ordinarily, I would be happy using UEFI, but at the moment I'm playing around with Linux live USBs, which will only show up in CSM mode (they do work in CSM mode).

I can't be 100% positive of this, but I suspect this is a case of the Linux USB drives being improperly prepared. Most modern Linux distributions support booting in EFI mode, including booting their installation and emergency tools in this way; however, some tools, like YUMI, omit the EFI boot loaders when they convert .iso files to USB boot media. The solution to this problem is to use another tool to prepare the boot media, or possibly to adjust options in the tool you are using. See this page of mine for more on this subject.

If you're using an old or obscure Linux live medium that lacks EFI-mode boot support, you may be able to add it yourself by installing a suitable boot loader and configuring it manually. This is likely to be a hassle and reqires a deeper-than-average understanding of Linux boot loaders. My Web page on this subject may be helpful, but you'll need to read at least the first couple of sections and the section(s) on the boot loader(s) you intend to use. You'll also need to be able to parse the medium's existing boot loader configuration so you can "translate" its configuration to your new boot loader.

Another option is to switch boot modes whenever you want to boot the Linux media. How you do this varies from one machine to another. In most cases, you can permanently set an option in the firmware so that it supports both EFI/UEFI and BIOS/CSM/legacy booting. With that done, the computer's built-in boot manager should show options to boot Windows or from the USB drive. (The built-in boot manager is usually accessed by pressing Esc, Enter, or a Function key at boot time; but details vary from one computer to another.) Alternatively, you could install my rEFInd boot manager and edit its refind.conf file so that scanfor is uncommented and biosexternal is among its options. This should cause rEFInd to show options for booting USB drives in BIOS/CSM/legacy mode, if they're inserted when you boot. (In some cases, you may need to press the Esc key in the rEFInd menu to get these media to show up, or uncomment the uefi_deep_legacy_scan option in refind.conf.)

One final comment: If Secure Boot is enabled, this feature can limit your options. Major Linux distributions like Ubuntu, Fedora, and OpenSUSE all support Secure Boot; but more obscure distributions might not. Likewise, if you install your own boot loader or use rEFInd, you'll have to either disable Secure Boot or jump through extra hoops to get it working, as described on this page of mine. You can usually disable Secure Boot without enabling the CSM, but I've heard reports of EFIs that link the two options.

  • Hi Rod, thanks for your answer. Unfortunately, it would appear that, as Ramhound established, my laptop's UEFI settings only allow one mode at a time - there's no "Both" or "UEFI/CSM" mode and no option like "Boot UEFI First". I used Rufus to prepare the USB, and I did see an efi folder or similar on the USB. I think it may just be a case of my laptop's UEFI being awkward, as I read on the manufacturer's website or forum that external devices would only boot in CSM mode. Fortunately, on my desktop it shows all devices in both modes (and can have UEFI and CSM enabled at the same time). – Dog Lover Apr 4 '17 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.