1

I followed the instructions here to publish my ASP.NET Core app to IIS. However, when I navigate to my site's address (i.e. localhost), I get the following error:

HTTP Error 502.5 - Process Failure Common causes of this issue: The application process failed to start The application process started but then stopped The application process started but failed to listen on the configured port Troubleshooting steps: Check the system event log for error messages Enable logging the application process’ stdout messages Attach a debugger to the application process and inspect For more information visit: http://go.microsoft.com/fwlink/?LinkID=808681

After enabling logging in IIS, I get this message in the log file:

failed to start process with commandline '"dotnet"

What's strange about this is that I have also tried running the app in an Azure virtual machine, with the same results. Therefore, I think this is definitely a problem with my app, and not with IIS.

Does anyone have an idea of what is causing this problem?

closed as off-topic by Ramhound, karel, user477799, DavidPostill Mar 31 '17 at 10:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is not about computer hardware or software, within the scope defined in the help center." – Ramhound, DavidPostill
If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.