1

So I can't install Samsung Kies 1 and SmartSwitch as I get this error message when running the installer:

The application has failed to start because its side-by-side configuration is incorrect

Full, untranslated message

Diese Anwendung konnte nicht gestartet werden, da die Side-by-Side-Konfiguration ungültig ist. Weitere informationen finden sie im Anwendungsereignisprotokoll. Weitere Details können auch mit dem Befehlszeilentool sxstrace.exe angezeigt werden.

I'm running a freshly-installed UEFI Windows 10 64Bit machine.

In the event log I see these errors (event id 33):

Activation context generation failed for "C:..\Smart_Switch_pc_setup.exe". Dependent Assembly Microsoft.VC90.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8" could not be found. Please use sxstrace.exe for detailed diagnosis.

SxsTrace doesn't give me more info. All other installers (except these 2) that I have run by now have been running just fine.

Some things I already tried:

  • Restart
  • Running sfc /scannow
  • Deinstalling all Visual C++ Redistributables for 64Bit (2005-2015), restarting, reinstalling them, restarting again
  • Just installing Visual C++ Redistributable 2008 64Bit
  • Installing Visual C++ 2008 Redistributable Package ATL Security
  • Running the installer as admin
  • The registry changes detailed here (I only have 1 version nr which also is properly set)
  • Cleaning and reinstalling .NET Framework
  • Checking for Windows updates

Please help.

3

Microsoft.VC90.DebugCRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8"

This message means the tool was compiled in Debug mode in Visual Studio 2008, so you need the VC++ 2008 Debug Runtime.

But this runtime is not allowed to be shared/redist via installer. So ask Samsung Support to release a new version of the software that is compiled in Release mode.

// Edit,

if it is MFC, install the 32Bit Visual C++ 2008 Runtime, because win32 = x86.

| improve this answer | |
  • Oh I made a mistake - it wasn't .DebugCRT but .MFC. Sorry and thanks anyways... – mYnDstrEAm Apr 3 '17 at 9:23
  • 1
    ok, I added the new link. you need the 32Bit DLL, not 64bit. – magicandre1981 Apr 3 '17 at 15:30
  • This fixed it - thank you! I thought I tried some 32Bit versions but apparently not the right (2008) one... – mYnDstrEAm Apr 5 '17 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.