2

I'm trying to create a logical partition inside an extended partition but gparted doesn't let me do it.

My setup:

  • System: Ubuntu 16.04
  • Partitioning software: gparted 0.25.0

HDD 1TB

  • /dev/sda1: extended partition (covers all the space)
    • /dev/sda6: 32GiB system root partition
    • /dev/sda7: 113GiB data partition
    • /dev/sda5: 664GiB main data partition
    • 114GiB Free space I want to use as new partition, not as a part of sda5
    • /dev/sda8: 8GiB swap

Do I have to umount the system root partition?

Is there a workaround?

Is it just a bug?

Why does this happen?

I don't want to run a live CD/USB just to create a partition.

Yes, I know partition numbers are not ordered, but I'm using UUID anyway so who cares. I also know there are almost 70GB missing. This is because GiB is not equal to GB, and the brands sell HDD with measuring unit of 10^12 bytes instead of 2^40 bytes.

  • How exactly gparted doesn't let you? Have you tried other tools (like fdisk, gdisk)? – Kamil Maciorowski Mar 31 '17 at 14:24
  • 2
    Please leave this question open (don't accept your own answer), so maybe someone will eventually explain to us what happened. I find it interesting. I have changed the question title and emphasized the "why?" part. – Kamil Maciorowski Apr 1 '17 at 22:23
  • 1
    maybe the correct question should be something like: why do logical partitions need a 1MB gap at each side in gparted? – Falk Apr 2 '17 at 14:07
  • this might have nothing to do with not using live session. from a live usb i had the same problem and solved in the same way. – user162573 Apr 19 '18 at 16:20
  • 1
    When do logical partitions happen to need 1MB gap at each side in gparted? on unix.stackexchange – user162573 Apr 19 '18 at 16:32
1

I solved it. All I've done is letting 1MB gap at each side of the partition and setting align to 'none'.

Still I don't understand why this is necessary.

| improve this answer | |
  • 1
    +1 Although this short answer gives a workaround only and explains nothing, I appreciate it could be a life-saver for someone with similar problem. – Kamil Maciorowski Apr 1 '17 at 22:23
  • How have you found about this trick? --- As it is the answer was short but efficient for me too (after solus linux failing to format and install on that partition; worked after formatting it in gparted as you said). - Only I wasn't able to format from a live usb, until I used those settings. This might have nothing to do with being in live session or not. – user162573 Apr 19 '18 at 16:16
  • @cipricus I had an intuition and tried it out. – Falk Apr 19 '18 at 16:23
  • Sometimes trying out is easier than read lot's of documentation and sourcecode. On the other hand just tring things can be dangerous. – Falk Apr 19 '18 at 16:27
  • the possible question that you phrased in a past comment : - unix.stackexchange.com/q/438773/32012 – user162573 Apr 19 '18 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.