2

I have a microSD card ("Lexar microSD RDR", according to Linux) which I previously used as "internal storage" for my Android 6 phone. However, at some point, I had to factory reset this phone; after which my phone did not longer recognise the SD card as internal storage; nor was it able to format the card.

Note: I only used the card for about 3 months as internal storage. Everything worked perfectly fine up until the factory reset, no physical damage was done to the card, and it should definitely not be near its lifespan yet.

What I've tried so far on Windows 10:

  • Try right-click and format. While it's a 16GB disk, Windows claims it only has a 16 MB volume (see later); and formatting it this way always fails: "Windows was unable to complete the formatting".
  • Opening Disk Management reveals this disk has 2 primary partitions: a 16 MB one; and a 14.90 GB one. Both are listed as healthy. However, trying to "Delete Volume" on either of them does nothing.
  • Using DiskPart, I selected the disk, tried both "clean" and "clean all". DiskPart claims both worked ("DiskPart succeeded in cleaning the disk"), but nothing actually happens. I cannot create a new primary partition afterwards ("The operation is not supported on a non-empty removable disk"). Note that there were no flags like readonly turned on!
  • Tried adding the registry key "Write Protect" under "Storage Device Policies" and restarting the computer; then repeating all the previous. No results.
  • Tried different card readers, both with and without those lock switches on the side.

What I've tried so far on Linux Mint 18.1:

  • Look in Disks, which shows me the same two partitions as before, but now with the names "android_meta" and "android_expand". Trying to delete either of them does nothing.
  • Tried the same with GParted. Deleting both partitions apparently works, but they instantly reappear.
  • Tried the same with fdisk, again, same results.

So, long story short: I seem to be completely unable to format the sd card. I don't care about the contents; I would just like to be able to use it again.

2
  • On Linux / Mint, are there any messages in the system log or dmesg after inserting the card & trying to format? Anything like "read only" or "write failed" would point to the card just going bad & not allowing any writes. It definitely could have gone bad somehow, maybe that's why a factory reset on the phone was required in the first place.
    – Xen2050
    Mar 31, 2017 at 16:05
  • @Xen2050 I do seem to get a bunch of error messages: usb 1-9: new full-speed USB device number 6 using xhci_hcd; usb 1-9: device descriptor read/64, error -71; ... ; device not accepting address 9, error -71; usb usb1-port9: unable to enumerate USB device
    – sTertooy
    Mar 31, 2017 at 16:14

6 Answers 6

1

I understand not all formatting programs are made equal, especially with regard to the handling of the security features of the SD/SDHC/SDXC protocols.

Firstly, if you know the exact brand / model /protocol, look for a specific formatting program on the manufacturer site. In your case, i would double check that what is written on the card fits what linux detected and start from there. This is your best chance to be able to access the protected area of the SD/SDHC/SDXC card and fully reformat it.

Second, you may want to try software like SD Card Formatter 4.0 that is supposed to be better than OS native formatting software for SD cards.

Some caveats (cf wikipedia link below): Reformatting an SD card with a different file system, or even with the same one, may make the card slower, or shorten its lifespan. Some cards use wear leveling, in which frequently modified blocks are mapped to different portions of memory at different times, and some wear-leveling algorithms are designed for the access patterns typical of FAT12, FAT16 or FAT32. In addition, the preformatted file system may use a cluster size that matches the erase region of the physical memory on the card; reformatting may change the cluster size and make writes less efficient.

You can find more details on this wikipedia page

4
  • I've looked on the manufacturer's website, they also recommend using SD Card Formatter 4.0. However, SD Card Formatter claims that the "The Memory Drive is write-protected".
    – sTertooy
    Mar 31, 2017 at 16:00
  • You may want to try this? tomshardware.co.uk/forum/… ?
    – wotter
    Mar 31, 2017 at 16:09
  • I'd already tried the first thing. I've tried using hdparm too now, but again, no result.
    – sTertooy
    Mar 31, 2017 at 16:22
  • @user102426 did you encrypt the card when it was on your phone? at this point, i would look if you can make the card seen again by your phone, maybe check android sites
    – wotter
    Mar 31, 2017 at 17:41
1

The card is simply broken. I ran into this thee times in the last two years, two being a Transcend cards, one SanDisk. Devices used were 2 Win phones (8 and 10), and one android.

I've tried Linux, Windows, Winphone, Android. Nothing will permanently format or delete anything from them. Many procedures will "fake" format or "fake" wipe the card.

My advice is, with SD card prices being what they are; don't waste too much time on it.

0

I do seem to get a bunch of error messages:

usb 1-9: new full-speed USB device number 6 using xhci_hcd
usb 1-9: device descriptor read/64, error -71
... 
device not accepting address 9, error -71
usb usb1-port9: unable to enumerate USB device

Those don't sound good, but it is an SD card and you must have it in a USB reader. So try:

  • a different card reader
  • a whole different computer

and see if it's any better. If it works, then it looks like a bad USB adapter or devices. Or, if you still get errors & can't write to the card, I'd say the card has just gone bad.

Maybe it's still new enough to be under warranty, and there's hope to get an exchange from the store or something.

0

Very simple procedure:

https://www.sdcard.org/downloads/formatter/index.html

Go here: Install the formatted. Open it and click format. I am pretty sure this will fix the issue.

0

The traditional way to do it under UNIX and other operating systems was to use a formatting program that would find all the bad sectors, put them in a file (inode), and leave the file un-linked to the file system directory tree with a positive reference count so all these bad sectors would never be accessed by the operating system. This only works if the operating system file-system is designed to support this feature, and I think most newer ones are not supporting it, but something old like NTFS(1993) or Fat32(1996) might have it, or the original Linux file system (ext2(1993?)), and certainly Unix's UFS(1969).

This code was developed in the days when hard disks didn't have a microprocessor controller. Now a days hard drives (and flash drives) are pushing the reliability envelope so hard that newly manufactured devices have MANY formatting errors. They all have smart controllers than find the errors at manufacturing time, at the hardware level, and hide the fact that there are bad sectors or tracks on your magnetic storage device. For a flash drive they also does wear-leveling (moving pages after a certain number of uses, keeping a reserve of 10% unused pages at all times.)

Most file system formatting programs have removed this functionality but there may still be ancient ones that support it. If it's an absolutely new flash drive you might search for this feature but if the drive is used, there was good advice above - the whole drive is failing and you should get rid of it as fast as possible.

0

What you want is to zero the drive with dd. Check this link for a more polished answer(which I am citing).

https://askubuntu.com/questions/142858/how-to-zero-out-a-drive

Go into GParted, identify X in /dev/sdX for your flash drive and run

sudo dd if=/dev/zero of=/dev/sdX

I have destroyed many flash drives with software and rescued just as many with dd. Once dd runs for a minute or so, cancel the process, format the drive, and it should work good as new.

What can happen is if the partition table gets screwed up, it can mess with most formatting tools. dd doesn’t care, it blasts right through with low level write commands and effectively destroys the boot record and partition table. Once that’s gone, really after a second or so, there’s no weird corrupted data to trip up high level formatting tools, and a reformat completes successfully using whatever GUI you like.

dd has worked for me where every other formatting tool has failed. It’s marvelously powerful. Be careful with it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .