15

I was working on my wordpress website and I accidentally changed the internal URL of the site and accessed it once. Since then chrome automatically redirects to that URL even though I have reverted everything. Everything works fine in every other browser (even chrome incognito) but regular chrome doesn't want to cooperate.

Problem:

  1. I type in mydomain.com
  2. Google redirects me automatically to mydomains.com
  3. I go to mydomain.com/uri. Works fine.
  4. I click on home from mydomain.com/uri which points to mydomain.com and chrome redirects to mydomains.com

I have flushed my DNS and sockets pools in chrome, I have cleared the DNS on windows as well. Not quite sure what else I can do?

2
  • What happens when you try the domain in a private browsing window? What about other browsers, and their 'private' modes?
    – FCTW
    Commented Mar 31, 2017 at 18:32
  • "Everything works fine in every other browser (even chrome incognito) but regular chrome doesn't want to cooperate." It's in my original question
    – Ortix92
    Commented Apr 1, 2017 at 10:18

1 Answer 1

22

Browsers these days often times cache redirects. You need to clear your file cache from before your mistaken change. From Stackoverflow

To force clear htaccess/redirect caches in Google Chrome:

  1. Go to Settings > Advanced > Privacy > Clear Browsing Data
  2. Select "Cached Images and Files"
  3. Click Clear Browsing Data
3
  • 1
    did not work for me Commented Feb 12, 2018 at 17:01
  • 5
    There is an Easy Link to this chrome://settings/clearBrowserData
    – JanBorup
    Commented Mar 22, 2018 at 11:42
  • Worked. But it was hard for me to relate the DNS related config to categorization "Cached Images and Files", not something like "DNS", not "Cookies and other site data"
    – Nor.Z
    Commented Dec 29, 2023 at 20:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .