0

I am completely unable to update intel hd graphics 4600 driver. I have tried using OEM drivers(from Toshiba) and Generic Intel drivers. I have tried the built in exe installers (setup.exe) and using device manager but everytime I get an error. Setup.exe say You don't meet minuium requirments Device manager says Your driver does not support this version of windows.

I have checked many times and downloaded 64bit Windows 10 version that I require.

I don't have a proper graphics card like amd or nvidia just a integrated intel hd graphics 4600

Hardware IDs: PCI\VEN_8086&DEV_0F31&SUBSYS_F9101179&REV_0E PCI\VEN_8086&DEV_0F31&SUBSYS_F9101179 PCI\VEN_8086&DEV_0F31&CC_030000 PCI\VEN_8086&DEV_0F31&CC_0300

EDIT:

Windows Update has managed to install updates itself for version 10.18.10.4425. Is this the lastest and is this trustable?

The reason I wanted updated drivers is becuase I thought I might be able to play my favourite game PvZGW2. On it's specification it says it requires a graphics card. But I have found many youtubers who have played without a card with low quality. When I open it says I need to update to Intel driver xx.xx.15.4251? I cannot find this driver so am assuming I have a higher version... When i launch the game the it just goes black and then says there was a problem making it crash da da da. Windows will now try and fix it.

DXDIAG: DXDIAG Thank You ! Could this be anthing? Problem signature:

P1: GW2.Main_Win64_Retail.exe

P2: 1.0.7.0

P3: 581be994

P4: igdusc64.dll

P5: 10.18.10.4425

P6: 5702a750

P7: c0000094

P8: 00000000002163ec

P9: 

P10: 
  • Trying the search drivers for me button on device manager says you are using the latest driver, Microsoft basic display adapter. – Bilbo Mar 31 '17 at 18:52
  • whats your toshiba laptop model ? that should help a lot. also did you try to download the intel drivers directly from intel ? you just have to know the right intel integrated model but yours seems to be intel hd 4600 but just check in device manager with the hardware ID to make sure – Fluffy Destroyer Mar 31 '17 at 18:55
  • When did this problem start? What Windows 10 build are you running. If you are running 1703 (which is build 15063) then you will have to wait or Intel to release an updated installer. – Ramhound Mar 31 '17 at 18:58
  • Toshiba laptop is C50-B-14D. Was working fine a few weeks ago, i tryed to boost my performance by installing new drivers from intel support then it all went wrong. If you mean hardware ids then this is what i get PCI\VEN_8086&DEV_0F31&SUBSYS_F9101179&REV_0E PCI\VEN_8086&DEV_0F31&SUBSYS_F9101179 PCI\VEN_8086&DEV_0F31&CC_030000 PCI\VEN_8086&DEV_0F31&CC_0300 Sorry but how do i find the build no. of windows? – Bilbo Mar 31 '17 at 19:02
  • It is in super low res but then when i click unistall in device manager is goes back to a high res again but bad quality and now doesn't show in device manager? – Bilbo Mar 31 '17 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.